Visionaire 5 released

  • #90, by wimfFriday, 24. November 2017, 23:03 2 years ago
    Wow, thank SimonS for this update.

    Forum Fan

    238 Posts


  • #91, by TinTinSaturday, 25. November 2017, 15:41 2 years ago
    There is some issue in turning character. I'm not sure that was in previous versions or not but many times it don't play it special when character is walking and don't stop yet.

    Forum Fan

    193 Posts

  • #92, by esmeraldaSaturday, 25. November 2017, 17:17 2 years ago
    I can't find the button to register the engine.
    I installed the new version and wanted to build a game. After I got the message that I needed to register the engine (makes sense, I deinstalled the old version and installed the new one, so I guess my registration of the old version got deleted) I searched the option to register - but can't find it.
    Could please someone point me to the right button?

    Great Poster

    385 Posts

  • #93, by afrlmeSaturday, 25. November 2017, 17:29 2 years ago
    Uninstall it. Redownload it from the licenses page on here. It should already be licensed when you download & install the full version from here.

    Imperator

    6816 Posts

  • #94, by esmeraldaSaturday, 25. November 2017, 17:43 2 years ago
    Thanks for helping, I did as you told me, but still get the same message.
    My internet connection is a bit wobbly - could that be the problem?

    Edit: ok, that's weird - building the game works on my desktop (win7) but not on my laptop (win10)
    On my laptop I still get the message that I'm not a registered user. I tried uninstalling an installing the engine several times an even deleted (that means renamed) the visionaire-folder in the App Data-folder, but I still get the message and can't register again.

    Great Poster

    385 Posts

  • #95, by TinTinSunday, 26. November 2017, 14:16 2 years ago
    Great news for Android: I tried shaders and shader toolkit on Android and works very well for me. There was a little drop FPS but not important. I thinks is related to my cell phone with 2GB Ram.
    Thanks a lot Simon for this great update  grin

    Forum Fan

    193 Posts

  • #96, by MachtnixSunday, 26. November 2017, 18:17 2 years ago
    Einige Script-Befehle werden in anderer Reihenfolge ausgeführt als in 4.2.5. Deshalb ist es mühsam, alte Projekte zu konvertieren, weil die gesamte Programmierung und die Aktionen umgestellt werden müssen.
    Einige Animationen sind fehlerhaft oder fehlen ganz. Keine Ahnung, wieso. Ich habe es mit webm versucht.
    Ich überlege mir deshalb ernsthaft, vorerst in 4.2.5 zu bleiben und mit dessen Einschränkungen zu leben, zumal ich mit dem Interface von v5 nicht arbeiten kann. Der Vorteil von 4.2.5 ist außerdem, dass es auf 32 bit UND auf 64 bit läuft, wohingegen v5 nur auf 64 bit geht.

    Some script commands are executed in a different order than in 4.2.5. That is why it is difficult to convert old projects because the entire programming and the actions must be changed.
    Some animations are faulty or missing altogether. Do not know why. I tried webm.
    So I'm seriously considering staying in 4.2.5 for the time being and living with its limitations, especially since I can not work with the v5 interface. The advantage of 4.2.5 is that it runs on 32 bit AND 64 bit, whereas v5 only works on 64 bit.

    Thread Captain

    1079 Posts

  • #97, by sebastianSunday, 26. November 2017, 21:06 2 years ago
    @Machtnix: Could you be more specific what you mean by that?

    For me it works still from top to bottom and i have no issues with my project(s) -and they use a lot of lua. There is no other way the engine would run through actions or scripts. They run, when they get called and in the order they get called.
    It depends a bit on how good the "code" is you are writing to ensure that it will not mess stuff up or take too long while another script running parallel is dependant of the success of that script.
    May the engine works more efficient now in some points to run through specific actions and if you use hard coded pauses or something like that to "guess" the speed it takes to finish it to running another action, you will have a bad time on other computers with other clock speeds or just when updating the engine itself. Thats not the problem of the engine though, but the code you write.

    Thread Captain

    2336 Posts

  • #98, by MachtnixSunday, 26. November 2017, 21:32 2 years ago
    Nun, meine Programmierkünste sind alles andere als professionell. Es wird wohl so sein, dass klitzekleine Logikfehler zu unterschiedlichen Ergebnissen in der Abarbeitungsreihenfolge führen. Da es aber in der alten Version nach 100 Mal Testen funktioniert, werde ich diesen Fehler sicher nie finden, ohne alles komplett neu zu machen. Dass die Laufzeit wohl nicht die (Haupt-)Ursache ist, zeigt, dass auf dem schnelleren PC mit 4.2.5 das Spiel genauso wie auf dem langsamen läuft, mit 5 jedoch nicht.
    Für ein neues Projekt in v5 starte ich dann bei Null und baue dort solange, bis es mit v5 funktioniert. Z.Z geht das nicht, wegen des kaputten Interface.

    Well, my programming skills are anything but professional. It will probably be that tiny logic errors lead to different results in order. But since it works in the old version after 100 times of testing, I'll never find that error without completely redoing everything. That the runtime is probably not the (main) cause, shows that on the faster PC with 4.2.5 the game runs the same as on the slow, but not with 5.
    For a new project in v5, I then start at zero and build there until it works with v5. Because of the broken interface I don't use v5.

    Thread Captain

    1079 Posts

  • #99, by MachtnixMonday, 04. December 2017, 23:38 2 years ago
    Es gibt einige Gründe, weshalb ich die finale Version 5 nicht verwenden kann:

    Die grafische Oberfläche ist noch sehr fehlerhaft. Am schlimmsten sind tatsächlich die überlappenden Menü-Icons links oben, was ein Zielen und Anklicken fast unmöglich macht. Und man wechselt doch sehr häufig zwischen den Bereichen! Das ist absolut nervig.

    Wie man sieht, überlappen sich zudem viele Menübuttons und Beschriftungen auf den einzelnen Menüseiten, manche gar nicht, manche mehr, so dass es mühsam wird, da sich das Richtige rauszupicken.

    Warum die Aktionsbereichseintragungen so nach links wegdriften, weiß ich auch nicht. Ist jetzt nicht wirklich schlimm, aber ärgerlich.

    Ärgerlich ist auch, dass ich beim Wechsel der Menüs immer wieder denselben 100%-Ausschnitt von der Kulisse bekomme. Das Programm merkt sich nicht die letzte Position und die letzte Vergrößerung. Jedesmal muss ich erneut suchen, wo ich zuletzt auf der Kulisse war. Es wäre bereits eine Hilfe, wenn wenigstens immer die ganze Kulisse angezeigt wird, dann brauche ich nur hinscrollen und reinzoomen.

    Aber der wirkliche Grund ist ein Absturz beim Anklicken der Personenanimationen. Das tritt jedes Mal auf. Es kann natürlich sein, dass in der Animation was kaputt ist, aber ich glaube, dass es in 5 RC2 mit derselben Datei noch geklappt hat. Leider habe ich diese Beta-Version nicht mehr, um es zu testen.

    Zudem wäre das Anvisieren der Animationsbuttons auch sehr mühsam, da diese sich ebenfalls überlappen. Man kann beim Größerziehen der Bereichsframes zwar etwas verbessern, aber wenn ich die Aktionen im ganz rechten Frame zu sehr an den Rand dränge, ist der Frame ganz weg und ich bekomme ihn nicht wieder (außer durch Neustart).

    Dass viele Animationen nicht abgespielt werden oder das Programm zum Absturz bringen, habe ich bereits gepostet. Den Grund dafür kann ich nicht nachvollziehen, außer dass dies bereits in 5 RC1 und 2 so war. Die neue Engine macht also irgendwas anders.

    Vielleicht gibt es ja hin und wieder unbemerkte Fehlerbeseitigungen, aber im Moment bleibt mir nichts anderes, als weiterhin die 4.2.5 zu benutzen. Die jetzige 5er-Version habe ich mir vorgestern heruntergeladen.

    Was schade ist, denn gerade im Lua-Editor sind doch nette Verbesserungen drin, die ich zu schätzen wüsste (in 4.2.5 gibts nur eine Textfarbe und keine Vorauswahl-Hilfe...). Nicht zu vergessen die anderen Neuerungen von R5, die ich natürlich gerne mal ausprobiert hätte. Vielleicht in einem gänzlich neuen Projekt, aber jetzt starte ich mein nächstes Projekt zwangskäufig in 4.2.5.

    Ich benutze ein Dualcore AMD mit 4 GB RAM und win 7 64 Bit. Sollte eigentlich reichen.


    ¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦¦


    There are some reasons why I can't use the final version 5:

    The graphical user interface is still very buggy. Worst of all, the overlapped menu icons at the top left, making it almost impossible to aim and click. And you change very often between the areas! This is absolutely annoying.

    As you can see, many menu buttons and captions overlap on the individual menu pages, some not at all, some more, so it is arduos to pick the correct one.

    I don't know why the action area entries drift so to the left. is not really bad now, but annoying.

    It is also annoying that I always get the same 100% cut-out from the backdrop when changing menus. The program does not remember the last position and the last magnification of the scene. Every time I have to look again where I was last on the scene. It would already be a help, if at least always the whole scenery is displayed, then I just need to scroll and zoom in.

    But the real reason is a crash when selecting the personal animations. This occurs every time. It can be possible that something is broken in the animation, but I believe that it worked well in 5 RC2 with the same file. Unfortunately I have this beta version no more to test it.

    In addition, the targeting of the animation buttons would also be very tedious, as they overlap as well (see on the picture). You can make it a little bit better by increase the frames, but if I push the actions in the right frame too much to the edge, the frame is completely gone and I do not get it again (except by reboot).

    That many animations do not play or crash The program, I have already posted. I cannot understand the reason for this, except that this was already the case in 5 RC1 and 2. So the new engine does something different.

    There may be unnoticed error eliminations now and then, but at the moment I have nothing else but to continue to use the 4.2.5. The current 5-version I downloaded the day before yesterday.

    Which is a pity, because in the Lua editor there are nice improvements that I would appreciate (in 4.2.5 there is only a text color and no pre-selection help...). Not to mention the other new features of R5, which I would have liked to try. Maybe in a completely new project, but now I will start my next project in 4.2.5. (which takes a year, I think...)

    I use a dual core AMD with 4 GB RAM and win 7 64 bit. Should actually be enough.

    Thread Captain

    1079 Posts

  • #100, by afrlmeTuesday, 05. December 2017, 00:19 2 years ago
    What a bizarre screen resolution you are using. It's squashing like that due to the screen not being wide enough I think. I guess Simon needs to some kind of code to check what the monitor/window resolution is to dynamically change the editor as needed.

    Actually, I just tried resizing the window & it seems to be more or less ok for me at around 1280px wide. The icons start overlapping if I go any lower than that. I'm not sure why it's overlapping so badly for you. Maybe something to do with your graphics card? Or not using the recommended resolution for your monitor? or maybe you need to update your gpu drivers?

    Imperator

    6816 Posts

Write post