Visionaire 5.0.4 update released

  • #30, by esmeraldaTuesday, 03. April 2018, 15:42 4 years ago
    Thanks for fixing the values in the dialog parts! :-)

    I have no clue how to use the sound system. I coulndn't figure out how to apply an effect to a sound, let alone what to do with the "events". So I will have to wait for the instruction video...  ¯\_(?)_/¯


    And thank you for this: "- animation center position controls limited to 1000"! 

    Great Poster

    458 Posts


  • #31, by wischnikWednesday, 11. April 2018, 13:24 4 years ago
    vielen dank für das update!

    anyways:
    is it only me, or is anyone else having problems with compiling a game? the moment i start building, nothing happens and the progress bar stays at zero percent — no increased cpu activity either. i work on a mac. i tried compiling to windows and mac.

    Newbie

    25 Posts

  • #32, by wischnikFriday, 13. April 2018, 19:57 4 years ago
    is it only me, or is anyone else having problems with compiling a game? the moment i start building, nothing happens and the progress bar stays at zero percent — no increased cpu activity either. i work on a mac. i tried compiling to windows and mac.
    anyone?

    Newbie

    25 Posts

  • #33, by SimonSFriday, 13. April 2018, 22:10 4 years ago
    Please post a screenshot of your problem and the logs.

    Thread Captain

    1550 Posts

  • #34, by wischnikSaturday, 14. April 2018, 12:57 4 years ago
    Please post a screenshot of your problem and the logs.

    hello simon,

    first screenshot is what happens when i "build" the game.

    and that's it. nothing is compiled. nothing moves. i can x out the progress window and proceed, but i can't actually cancel the "build". where would i find the logs for this?

    also i only now noticed another problem correlating with the update. the full-screen player is not working anymore — only the window-based player. (i'm using a custom resolution of 180 to 112.) could this have to do with my retina display? using the buggy fullscreen display i'm also not able to use my mouse — it seems to be stuck on the right site of the screen.

    also added screenshots of working player in window and faulty fullscreen player.



    thanks in advance.

    Newbie

    25 Posts

  • #35, by LebosteinSaturday, 14. April 2018, 21:15 4 years ago
    Please, please, please add a possibility to move/pan the screen/scene for systems without a middle mouse button!!!

    Key Killer

    620 Posts

  • #36, by afrlmeSaturday, 14. April 2018, 22:02 4 years ago
    Please, please, please add a possibility to move/pan the screen/scene for systems without a middle mouse button!!!
    +1 seconded. Either add a keyboard shortcut (spacebar) or a hand tool option on the toolbar above any of the preview windows that allow canvas dragging.

    Imperator

    7156 Posts

  • #37, by LebosteinMonday, 16. April 2018, 13:41 4 years ago
    @AFRLme: Thanks. Yes, a hand tool was a good idea....

    By the way: there is a bug with the "animation center" in animation editor (it seems for Spine files only), if the canvas was moved with the middle mouse button. In that case, setting the "animation center" produces wrong values an the crossed lines for marking the point are out of sight...

    Key Killer

    620 Posts

  • #38, by denis-Monday, 16. April 2018, 14:03 4 years ago
    For me it's not so bad using the middle mouse button...
    maybe can choose the modality  from the setting menu should be an idea...

    Thanks

    Newbie

    73 Posts

  • #39, by afrlmeMonday, 16. April 2018, 17:47 4 years ago
    For me it's not so bad using the middle mouse button...
    maybe can choose the modalyty  from the setting menu should be an idea...

    Thanks
    Aye, we meant as an optional toolbar button or keyboard shortcut for those people that are using a mac or laptop & don't have access to a middle mouse button. Magic mouse/pad doesn't have a middle mouse button. Some laptop touchpads only have left & right mouse buttons.

    Imperator

    7156 Posts

  • #40, by SimonSMonday, 16. April 2018, 23:56 4 years ago
    @wischnik It seems like you don't have write access to your export folder or it doesn't exist. I'll check on the retina issue later, have a high dpi display myself.

    Thread Captain

    1550 Posts