libpng error: IHDR: CRC error

  • #1, by smac96Tuesday, 16. January, 11:00 9 months ago
    Hi,

    What could be the problem if the game doesn't start at all and the stderr.txt file containt this: "libpng error: IHDR: CRC error"?

    Thanks for any help!

    (Win 10 64 bit, Visionaire 3.7)

    Newbie

    96 Posts


  • #2, by sebastianTuesday, 16. January, 12:16 9 months ago
    I know this error from another software... 
    mostly caused by invalid png images (color profile and such stuff) 

    In case of VS im not sure though

    Thread Captain

    2230 Posts

  • #3, by smac96Tuesday, 16. January, 12:23 9 months ago
    Maybe not a Visionaire error but instehad a conflict with another software or hardware component?

    Newbie

    96 Posts

  • #4, by SimonSTuesday, 16. January, 12:40 9 months ago
    Visionaire 3.7 has a very old libpng, so you need to set the generated pngs to maximum compatibility.

    Pngs have a format with header part, that has a checksum, if that doesn't match, there are errors, it's also possible that the png is a newer standard and the libpng doesn't understand them.

    Thread Captain

    1127 Posts

  • #5, by smac96Tuesday, 16. January, 12:47 9 months ago
    Visionaire 3.7 has a very old libpng, so you need to set the generated pngs to maximum compatibility.



    Pngs have a format with header part, that has a checksum, if that doesn't match, there are errors, it's also possible that the png is a newer standard and the libpng doesn't understand them.

    Thanks SimonS!

    Newbie

    96 Posts

  • #6, by smac96Tuesday, 16. January, 12:53 9 months ago
    Do you know why only one player so far had this issue but others don't?

    Newbie

    96 Posts

  • #7, by SimonSTuesday, 16. January, 12:57 9 months ago
    Maybe the files are corrupted while downloading. Steam has an option to check the files.

    Thread Captain

    1127 Posts

  • #8, by smac96Tuesday, 16. January, 13:22 9 months ago
    Maybe the files are corrupted while downloading. Steam has an option to check the files.

    Thanks!

    Newbie

    96 Posts

  • #9, by LebosteinTuesday, 23. January, 12:57 9 months ago
    @smac (Stefano Maccarinelli?): Have you considered an update to Visionaire 4? Visionaire 3.x was very sluggish, memory-hungry, error-prone and has very long load and save times. And it is from 2012 and problems with current operating systems like Windows 10 are possible. Visionaire 4 was rewritten and it runs much faster and more powerful than Visionaire 3.x.

    Key Killer

    576 Posts

  • #10, by smac96Tuesday, 23. January, 13:11 9 months ago
    @smac (Stefano Maccarinelli?): Have you considered an update to Visionaire 4? Visionaire 3.x was very sluggish, memory-hungry, error-prone and has very long load and save times. And it is from 2012 and problems with current operating systems like Windows 10 are possible. Visionaire 4 was rewritten and it runs much faster and more powerful than Visionaire 3.x.
    Hi! Yes. We considered it and we probably do it. We already bought the license. It will of course take a lot of time to re-test everything because the game is huge but the main problem is that using a newer version of Visionaire will make the current savegames incompatible. If it's not a problem for the players I think it will be ok to do it.

    There are hundreds of people that played/are playing the game and right now only very few of them directly reported us major problems. Unfortunately one of the players that had big issues playing was a reviewer of an important website for point and click lovers and the note she gave us really hurts a lot! Of course she had the full right to write what happened to her and let other players know that they might have problems too. This is important for us. Luckily the majority of reviews are positive and we're very happy about it! Anyway, after so many years of hard work and huge sacrifices for a 2-person studio it's very sad and frustrating to receive critics mostly because of the old buggy 3.7 game engine roll

    Newbie

    96 Posts

  • #11, by smac96Tuesday, 23. January, 15:04 9 months ago
    After some tests with version 4.2.5... I think we could update the game sooner as expected and let the players decide which version play wink

    Newbie

    96 Posts

Write post