Way to disable clicking during long character animations?

  • #1, by pixelgeistTuesday, 26. June 2018, 08:28 2 years ago
    Hi all, I have a few longish (3-4 second) animated sequences that I have my character perform, in gameplay... If I click anywhere on the screen during one of these actions it is interrupted before the sequence is able to complete... Is it possible to disable clicks, or other inputs for the duration of an animation? Or is there another way I can go about approaching this? Any help is greatly appreciated as always.

    Newbie

    16 Posts


  • #2, by esmeraldaTuesday, 26. June 2018, 08:45 2 years ago
    You could wrap the animation in a cutscene. -> action part begin/end of cutscene
    This disables mouseclicking but the scene can be skipped with escape-key.

    Great Poster

    368 Posts

  • #3, by afrlmeTuesday, 26. June 2018, 10:09 2 years ago
    As Esmeralda said, you need to wrap it. Though you have 3 choices here.

    1. wrap the animation between begin cutscene & end cutscene action parts - can be skipped with ESC key.

    2. wrap the animation between hide cursor & show cursor action parts - same as cutscene wrapper but can't be skipped.

    3. there's an option in the main game settings section of the editor called disable interaction during character anim, if you set that to only for manually started animation, then it will disable interaction whenever you manually start a characters animation, or if you set it to for all animations, then it will disable input whenever the character is doing anything other than playing an idle animation or a walk animation.

    Imperator

    6771 Posts

  • #4, by esmeraldaTuesday, 26. June 2018, 10:53 2 years ago
    3. there's an option in the main game settings section of the editor called disable interaction during character anim, if you set that to only for manually started animation, then it will disable interaction whenever you manually start a characters animation, or if you set it to for all animations, then it will disable input whenever the character is doing anything other than playing an idle animation or a walk animation.
    I wasn't aware of this posibility. Is it new in visionaire 5 or was it there before and I just never saw it???

    Great Poster

    368 Posts

  • #5, by afrlmeTuesday, 26. June 2018, 11:11 2 years ago
    Always there as far as I know. It doesn't hide the mouse cursor or set it to the inactive cursor - if you provided one, just prevents the user from clicking on anything or updating the character position, however the object/character names still show up when you hover over them so it's hard to know that interaction is disabled. The lipsync demonstration video I recently uploaded had it enabled & was preventing me from clicking on the lip sync test scene object I'd setup because my character was busy picking his nose (a random animation).

    Imperator

    6771 Posts

  • #6, by pixelgeistWednesday, 27. June 2018, 04:05 2 years ago
    Thank you both so much!  That is exactly what I was after... In my case I set disable interaction during character anim to all animations.  It gave me the behavior I wanted without having to wrap multiple animations.

    Just want to say the support I have gotten on this forum has been amazing.  Thanks again!!

    Newbie

    16 Posts

Write post