Visionaire RC0 Update

  • #130, by brut69Thursday, 25. May 2017, 16:21 4 years ago
    The scrolling doesn't work properly on large scenes. I already made a thread about it but I thought I should mention it here as well.

    Great Poster

    265 Posts


  • #131, by MachtnixTuesday, 30. May 2017, 21:24 4 years ago
    Insgesamt kann ich mich noch nicht so recht an das neue Aussehen gewöhnen. Das hängt zuallererst damit zusammen, dass die Schrift schlecht zu lesen ist. Der Kontrast ist zudem viel zu matschig. Gibt es auch eine "helle" Variante der Oberfläche (mit knackiger Schrift)? -> siehe Bild 1

    Das zweite doofe Ding ist, dass das Log in der Kommandozeile irgendwie nicht funktioniert. Ich kann zwar in einzelne Untermenüs (z.B. Values usw.), aber das wichtigste Werkzeug, um meine Programmierung zu überprüfen (mit print und Werteanbfrage usw.) war immer das Log. Was muss ich dazu einstellen? -> siehe Bild 2

    Thread Captain

    1093 Posts

  • #132, by sebastianTuesday, 30. May 2017, 21:33 4 years ago
    Du kannst zwischen hellem und dunklem Design wählen, indem du unten rechts im Programm auf den Schiebeschalter klickst. Das helle Design ist kontrastreicher und sollte die von dir empfundene "Unschärfe" reduzieren. 

    Was das log angeht bin ich ratlos. Bei mir klappt dies ohne Probleme beim eingeben von "print log" in der Konsole oder öffnen der Logdatei selbst. 

    Thread Captain

    2346 Posts

  • #133, by MachtnixTuesday, 30. May 2017, 21:44 4 years ago
    Du kannst zwischen hellem und dunklem Design wählen, indem du unten rechts im Programm auf den Schiebeschalter klickst. Das helle Design ist kontrastreicher und sollte die von dir empfundene "Unschärfe" reduzieren. 

    Was das log angeht bin ich ratlos. Bei mir klappt dies ohne Probleme beim eingeben von "print log" in der Konsole oder öffnen der Logdatei selbst. 
    OK, habs gefunden. Danke. Es ist tatsächlich hell, aber dennoch bleibt die Schrift "extradünn". In beiden Varianten habe ich leider einige Schwierigkeiten. Mmh, mal sehen. Welche Schrift wird denn vom Editor verwendet? Vielleicht kann ich die in Windows austauschen?

    Ja, das" print log" war immer meine allerhäufigste Tätigkeit in 4.2.5. Vielleicht muss ich dazu irgendwas schrauben? Die Schrift in der Kommandozeile wird ja immerhin dargestellt (bei einem falschen Grafik-Font war die auch schon mal verschwunden gewesen...). Log steht auf "Info" - aber mehr kann ich gar nicht ändern, oder?

    Thread Captain

    1093 Posts

  • #134, by NigecTuesday, 30. May 2017, 21:55 4 years ago
    At the beginning of the month when I built a game, it would download the visplayer kit for you, that no longer happens, it just says "not available" the ones on the site appear to be for V4.2.5

    Key Killer

    591 Posts

  • #135, by sebastianTuesday, 30. May 2017, 22:07 4 years ago
    OK, habs gefunden. Danke. Es ist tatsächlich hell, aber dennoch bleibt die Schrift "extradünn". In beiden Varianten habe ich leider einige Schwierigkeiten. Mmh, mal sehen. Welche Schrift wird denn vom Editor verwendet? Vielleicht kann ich die in Windows austauschen? 
    Du könntest den Skin bearbeiten und die Font entweder austauschen (DINPro-Light.ttf) oder eine neue Font in den Skin-Ordner schieben und die .css Datei anpassen. 

    Kann ich aber nicht unbedingt empfehlen, da ich nicht weiß ob es an bestimmten Stellen dann zu Problemen kommt. Spätestens nach einem Update ists dann auch wieder resettet.

    Ist aber machbar:



    Das Log sollte funktionieren ohne etwas einzustellen. Selbst wenn du in den Optionen das Loglevel umstellst (egal wohin), sollte hier zumindest das Log laden und einige Start-Sachen anzeigen. Die Meldung lässt eher darauf schließen, dass etwas anderes Faul ist. Was allerdings da genau nicht stimmt kann wohl eher nur ein Dev sagen.


    At the beginning of the month when I built a game, it would download the visplayer kit for you, that no longer happens, it just says "not available" the ones on the site appear to be for V4.2.5
    If i remember correctly the ones on the wiki page were updated... 

    Thread Captain

    2346 Posts

  • #136, by joemidWednesday, 31. May 2017, 02:13 4 years ago
    At the beginning of the month when I built a game, it would download the visplayer kit for you, that no longer happens, it just says "not available" the ones on the site appear to be for V4.2.5
    I've had this problem sporadically.  It seems to be solved by saving, closing VS, and restarting. 

    Newbie

    87 Posts

  • #137, by NigecWednesday, 31. May 2017, 13:07 4 years ago
    Thank you Joemid, that indeed worked smile

    I think I had tried saving yesterday but I just saved and tried to build, it seems you need to save when you get the save prompt as VS closes


    Key Killer

    591 Posts

  • #138, by MachtnixThursday, 01. June 2017, 13:07 4 years ago
    What is the "Visplayer Kit"? I still use 4.2.5, because of 32 bit. But all player functions work well in 4.2.5 (I believe).

    Thread Captain

    1093 Posts

  • #139, by sebastianThursday, 01. June 2017, 22:50 4 years ago
    What is the "Visplayer Kit"? I still use 4.2.5, because of 32 bit. But all player functions work well in 4.2.5 (I believe).

    In vs5 it auto downloads your needed stuff as far as i understand.

    Thread Captain

    2346 Posts

  • #140, by sebastianThursday, 01. June 2017, 22:57 4 years ago
    I discovered a big bug which makes it not possible for me to create new interface button images while i was creating a new tutorial video:

    As soon as i select an image for a button the editor freezes and throws "errors" in the console. I assume that the path it mentiones there is hard coded into the engine because it leads to a path for simon (which is not my name ^^) and also to a cpp file.


    With this bug i am unable to create anything further until this gets fixed roll



    Thread Captain

    2346 Posts