New Version released: Visionaire Studio 4.0 RC

  • #10, by afrlmeSunday, 11. May 2014, 13:38 8 years ago
    (e.g. '<pa350ms>' waits for 250 milliseconds in case there is no speech output)

    Really? razz


    hehe! I think Thomas needs to go back to school? his math skills are obviously worse than mine. grin

    Imperator

    7008 Posts


  • #11, by EinzelkämpferSunday, 11. May 2014, 14:19 8 years ago
    I just tried to make use of the new TTF support. But nothing is showing up in the game.

    The cursor behaves as expected: it disappears for the time the text is supposed to show up and reappears afterwards. But the text itself stays absent.

    I tried different TTF files (just in case), including Arial.

    Newbie

    81 Posts

  • #12, by afrlmeSunday, 11. May 2014, 14:29 8 years ago
    yeah having issues myself trying to find a working ttf/otf file or whatever.

    If you click on the icon that usually shows the squares around the font characters then it shows some font but it looks like gibberish.

    I'm sure Simon will give us a rundown on how it works, when he can.

    Imperator

    7008 Posts

  • #13, by SimonSSunday, 11. May 2014, 15:44 8 years ago
    Don't know whats the problem. It works here. Gimme something to reproduce or a screenshot.

    How do you import these fonts ?
    What I do is:
    1. new font
    2. settings / check truetype font
    3. import font (must be inside your ved branch as images)
    4. switch to preview and click the icon top left

    You might need to adjust your settings, normally these fonts have a big outline + shadow.

    Thread Captain

    1460 Posts

  • #14, by SimonSSunday, 11. May 2014, 15:47 8 years ago
    I still have the bugs in the Mac Editor:
    Can’t type numbers in the fields
    Can’t use the color-picker (e.g. in the sprite emitter)

    The numbers get selected once you type them so you must type while unselecting them, I didn't find a better solution. For the color selector you might need to move your cursor a little bit further over the screen, it's also a dirty fix wink

    Thread Captain

    1460 Posts

  • #15, by EinzelkämpferMonday, 12. May 2014, 13:33 8 years ago
    Here is what I have done:
    - New project with minimal requirements
    - Adding new font
    - Set new font to TrueType, selecting "arialbd.ttf" (copied to project folder before)
    - Set font size to 20.0 (not really necessary, but looks better in preview)
    - Looking at preview by clicking the "A" on the Font tab: Looks great!
    - Adding some text to the "Look at" action for the scene object "Rock" (the minimal configuration project had this text set by default in previous Visionaire versions)
    - Change selected font in game settings (Action text) and character settings
    - Add global right click action in order to be able to use the "Look at" command in-game (got lost in the minimal configuration project in the latest Visionaire version)

    START THE GAME: Looking at the rock does not display any text.

    - Change font in character settings back to the default (png) font.

    START THE GAME: Looking at the rock displays the text in the old-fashioned way.

    (Windows version, Win7 64bit)

    Newbie

    81 Posts

  • #16, by afrlmeMonday, 12. May 2014, 14:03 8 years ago
    haha, just realized that it's not generating gibberish in the preview (when I click on the "A" button to preview the text. It is displaying it upside down. I'm using a build David gave me from the day after the release of the RC version.

    It does display the text in game but it doesn't display in the colors I set, nor does it show the color changes in the preview screen. Also setting the colors was a pain as it required you to drag across the screen itself instead of across the color bar & doesn't allow us to type in colors either.

    Win 8 Pro (64 bit)

    Imperator

    7008 Posts

  • #17, by HellVanSingMonday, 12. May 2014, 16:34 8 years ago
    What about an internal updatefunction, so you needn't to go to the visionaire homepage to get an reinstall the new version.

    Newbie

    67 Posts

  • #18, by NimosMonday, 12. May 2014, 18:30 8 years ago
    Here is what I experienced when using the TTFs:
    It only works when I uncheck the border. when the border is activated there is no text displayed. shadow is working fine.
    also the colors are messed up. when a new font is created the color is set to white as standard. but the text in the preview and the game is displayed in cyan.
    when I try to adjust a color value the slider jumps automatically all the way to the left and stays there. its stuck so it can't be set anymore.

    On a different note:
    the dialogs still aren't working in the 4.0 RC mac editor as someone mentioned in this thread:
    http://www.visionaire-studio.net/forum/thread/two-mac-errors...
    hope you guys can fix this as soon as possible. without dialogs it's not the same ;-)

    otherwise I love visionaries and the fact that there is now a mac editor!

    (MacOSX, 10.9)

    Newbie

    12 Posts

  • #19, by BigStansMonday, 12. May 2014, 18:49 8 years ago
    Thanks for report smile

    Great Poster

    361 Posts

  • #20, by SimonSMonday, 12. May 2014, 19:43 8 years ago
    @einzelkaempfer: Have you set a name for the rock ? Notice it is not set in the template. I have this working fine.

    @AFRLme: yeah, know this bug, is only the version you got. Fixed it like two hours later, but didn't know it was in your build.

    @HellVanSing: Would love that, maybe in 4.1 or so.

    @Nimos: The color selector has an offset problem, you often need to move the mouse over the whole screen while clicking. Please explain whats up with the border, notice that a font with many outline may take a lot of time to generate, so don't use border there. I take a look into dialogs some time.

    Thread Captain

    1460 Posts