Memory issues

  • #1, by minibigsMonday, 12. January 2015, 21:48 6 years ago
    Hi, I started using VS yesterday & apart from the following issue I am pleased with it, so keep up the good work.

    I have VS 4.1, build 1177, downloaded yesterday.

    I am experiencing repeated memory crashes when using VS. These seem to happen regardless of what I am doing in VS at the time, the crashes do not seem to be related to loading large graphics, etc., as they occur when I am just generally editing, changing interface options, etc. Memory usage creeps up as I use it, until after I have made perhaps a dozen changes my system runs out of memory.

    Here are the details of a typical incident:

    SYSTEM DETAILS:

    Physical memory is 28% used of 4gb before opening VS (system reports 3.68gb usable), so 2.6496gb available to Visionaire to run.
    System is Win 7 home premium 64 bit.
    Cpu is Intel I5-4670 3.40Ghz.

    GAME EDITOR OVERVIEW (as shown in the editor, after loading a saved game:

    Total game size is 15kb
    1 scene 368 bytes
    1 character 674 bytes
    1 interface 318 bytes
    1 font 279 bytes
    17 animations 6 kb
    4 cursors 352 bytes
    12 texts 1 kb
    Game properties 947 bytes.

    The total size of all the graphics I am using including all sprites, etc., is 939 kb. So if VS held all these in memory + it's game overview figures = 954 kb.

    Again, if all held in memory this should leave 1.7gb available for VS to process in.

    Memory usage shoots up to 80+% then my systems issues warning messages re. short on memory. If I do not close VS at this point, I get VS failing with an exception error. No dumps have been produced to date.

    Any help much appreciated, as I cannot develop with it until this is resolved.

    Another minor connected issue is after the first crash, when VS is restarted the pop up window to select a new game, load existing, etc. is shown, but no CONTINUE button appears, but hitting ENTER after selecting an option works OK anyhow.

    Regards,

    Steve Fifield.

    Newbie

    79 Posts


  • #2, by minibigsMonday, 12. January 2015, 23:35 6 years ago
    UPDATE..........

    I noticed my video card (Intel HD 4600) had a very out of date driver (version 9), so I updated it to the latest version, 15.36.7.64.3960.

    The memory issues seem to have been resolved, memory has not gone over 50% since the upgrade.

    But, a new issue is that when I play a built VS game on a 1920 X 1080 monitor, the game plays in about the left 1/3 of the total screen size, with the top & left borders not on screen & the background picture does not line up with the window borders. This did not happen before the update, the game player successfully using the whole of the screen.

    I'm trying to resolve this now.

    Newbie

    79 Posts

  • #3, by minibigsTuesday, 13. January 2015, 13:58 6 years ago
    I've closed this, as memory is no longer an issuw & opened another thread re display issue.

    Newbie

    79 Posts

Write post