Full screen won't work on Surface Book with Windows 10

  • #1, by korpseFriday, 21. October 2016, 17:34 A year ago
    Hello guys!

    We're currently testing our game, and found an interesting bug: the game won't work in full screen on Surface Book with Windows 10. Any idea what could cause this? The game works just fine on all other computers we tested it with.

    We're using Visionaire Studio 4.3.

    Newbie

    25 Posts


  • #2, by sebastianFriday, 21. October 2016, 17:42 A year ago
    4.3? I guess this isnt possible yet... 4.2.5 is the latest version right now

    does the game work in window mode? 
    What does the log say? 

    Thread Captain

    1997 Posts

  • #3, by AFRLmeFriday, 21. October 2016, 18:12 A year ago
    What? You got VS 4.3 before me! That's PREPOSTEROUS! Right I'm off to bitch & piss & moan at Simon & Thomas for not giving me access to it first! razz

    Just joking. wink

    Visioniare Studio 4.2.5 is the current public version. Is there an option to run in compatibility mode? If there is, try setting it to windows 7 or 8.

    VS is known to be a little buggy with windows 10, but should probably be ok in 4.3 - at least I assume it will be a lot more stable - there will also be support to export for additional platform targets too - as you probably already know if you've scrolled down the new VS homepage thing.

    Imperator

    5833 Posts

  • #4, by NigecFriday, 21. October 2016, 19:06 A year ago
    I'm on Windows 10 but PC, none of the games I've played have had issues, but I don't have a touch screen, which maybe the reason?

    actually do a web search there is general known issues with games running full screen, drivers, Nvidia settings, display scaling to name but a few

    Great Poster

    317 Posts

  • #5, by schinkenThursday, 12. October 2017, 20:41 3 months ago
    It might be Screen DPI related (as your solution #2 and #3 indicate) but considering alt+enter works it's either a problem with VS (not reading the DPI (especially on high DPI screens) correctly and modify the needed parameters unless you sort of refresh the fullscreen with alt+enter) or it might be a windows problem in that VS is reading the DPI related stuff correctly but windows is not giving out the correct information unless alt+enter happens.

    Idea: try a lua solution?

    https://wiki.visionaire-tracker.net/wiki/GetWindowMode tells you if you're in fullscreen or not, check it during startup (maybe an empty "startup" scene as first scene with only this script?)

    Newbie

    4 Posts

  • #6, by adventure-birdThursday, 28. December 2017, 11:52 3 weeks ago
    I have Visionaire Studio R5 starting problems on a surface book 2. If I start the editor program I get displayed only a black screen.
    I already tried different compatibilty modes, resize the resolution settings, administration start mode etc.

    But til now nothing helped me. 
    Are there any solution or ideas for the problem?

    Newbie

    18 Posts

  • #7, by sebastianSaturday, 06. January, 02:28 2 weeks ago
    I have Visionaire Studio R5 starting problems on a surface book 2. If I start the editor program I get displayed only a black screen.
    I already tried different compatibilty modes, resize the resolution settings, administration start mode etc.

    But til now nothing helped me. 
    Are there any solution or ideas for the problem?
    Do you have any information about the system specifications?
    I can only assume that the integrated graphics of that tablet are not capable of using the shader driven interface...


    Thread Captain

    1997 Posts

  • #8, by adventure-birdSunday, 07. January, 12:22 A week ago
    I find a way to start the application on a Surface Book 2 by removing the tablet monitor device from the body. Start the application will - I assume - start with the intern graphic card from the tablet instead of the Nvidia 1050. The GUI is visible now. After attaching again the application works as expected!

    So try it out if you run in similar problems.

    Newbie

    18 Posts

  • #9, by sebastianSunday, 07. January, 18:26 A week ago
    I dont have a similar installation, but the issue you mentioned is known. AT least simon mentioned it. The engine does not work well if you have a two gpu system. This was also mentioned a few times here in the forum. You have to use the internal card for this.

    Thread Captain

    1997 Posts

Write post