Welche Version Visionaire5_ RC2 ?

  • #10, by MachtnixSunday, 27. August 2017, 20:31 4 years ago
    Anmerkung: funktioniert in der 4.2.5 auch schon nicht. 

    Thread Captain

    1093 Posts


  • #11, by sebastianSunday, 27. August 2017, 21:33 4 years ago
    ..und die Lautstärkeregelung  reagiert auch nicht fein.
    Soll man in so einem Fall (vermutlich Bug) an das Team schreiben oder an wen wendet man sich ?
    Ich gehe mal davon aus, dass SimonS schon mitliest. Er sollte das also hoffentlich schon auf seine Liste fürs nächste Bugfixig gesetzt haben. Gegebenenfalls aber erst am Montag, da ich nicht weiß wie der das mit Wochenendarbeit hält razz

    Thread Captain

    2346 Posts

  • #12, by MachtnixMonday, 28. August 2017, 03:28 4 years ago
    Da die Balance intern sicher über GetSoundProperty (CMS) geholt und über SetSoundProperty (CMS) angesteuert wird, könnte man ja ein kurzes Script schreiben, um zu sehen, ob nur die  Editorfunktion inaktiv ist oder ob das Visionaire-Objekt selbst nicht funzt.

    https://wiki.visionaire-tracker.net/wiki/GetSoundProperty_(CMS)

    Balance in der Kulisseneinstellung ergibt für mich aber irgendwie keinen Mehrwert, weil ich ja meist einzelne Objekte von rechts nach links (und umgekehrt) mit dem Pan-Regler begleiten möchte. Z.B. ein vorbeifliegendes Raumschiff: von dort, wo das Objekt sich befindet, soll auch der Ton herkommen. Die Hintergrundmusik oder alle anderen Geräusche sollen natürlich mittig stehenbleiben. Stelle ich jedoch den Balance-Regler für die komplette Kulisse z.B. nach ganz links, kann ich das im Spiel auch nicht ändern, und alle Geräusche auf der Kulisse wären immer ganz links; ich brauche also wahrscheinlich sowieso Lua, um das im Spiel anpassen zu können. Oder habe ich da was falsch verstanden?

    Thread Captain

    1093 Posts

  • #13, by BroeselMonday, 28. August 2017, 06:10 4 years ago
    Hallo Machtnix ...

    bin vollkommen deiner Meinung zum Thema Sound/Kulisseneinstellung.

    Danke auch für Link...bin aber LUA-Laie. Ich denke mal, das ich früher oder später nicht daran vorbeikommen werde und würde mich über Tipps/Links freuen, die einem Lua-Laien den Einstieg ermöglichen.


    Hi sebastian,

    es ist gut zu erfahren, das die Profis die Posts mitlesen..habe ich nur vermutet... aber eben nicht gewußt.

    Newbie

    27 Posts

  • #14, by MachtnixMonday, 28. August 2017, 18:08 4 years ago
    Ich probier mal ein bisschen rum. So kompliziert kann das sicher nicht sein.

    Als ein schlimmeres Manko empfinde ich übrigens, dass "Rückgängig" im Script-Editor nicht funktioniert (wie schon in 4.2.5). Ganz besonders da macht man doch viele Schreibfehler...

    Ach ja, noch ein Handicap: der Kommandozeilen-Editor ist wirklich toll, hat aber einen gravierenden Fehler, der das Arbeiten mit ihm fast unmöglich macht: man kommt nicht an die Informationen auf der rechten Seite! Ich kann zwar den Editor so weit aufziehen, wie mein Spiel breit ist, aber die Zeile wird dann irgendwann abgeschnitten und das, worauf es ankommt, kann ich meist nicht mehr lesen- u.a. weil vielleicht die Links oder die Befehle bereits sehr lang sind.

    Zeile 153 z.B. will mir etwas über die fehlerhafte Lua-Zeile berichten, aber ich komme nicht ran.

    Die tausend Fehlermeldungen darüber sind übrigens der Hinweis, dass einige Animationen in RC2 nicht funktionieren. Ich habe noch nicht rausgekriegt, woran es liegt (sind bereits im webm-Format), deshalb bleibe ich vorerst in 4.2.5.

    Thread Captain

    1093 Posts

  • #15, by BroeselMonday, 28. August 2017, 19:04 4 years ago
    Da kann ich leider nicht mitreden. Du hast Lua wohl recht gut verinnerlicht !
    Habe vor 7 Stunden neuen Post gesendet - vielleicht neuer Bug in Vis5-RC2.
    Habe aber noch keine Bestätigung erhalten.

    Newbie

    27 Posts

  • #16, by MachtnixMonday, 28. August 2017, 21:04 4 years ago
    Lua verinnerlicht? Nein, überhaupt nicht. Aber ich fürchte mich nicht davor, in den schwarzen Lua-See zu springen, wenn es denn sein muss. Allerdings ungern. Das  Rumprobieren ist oft sehr langwierig, frustrierend und es gibt viele Rückschritte. Zudem ist es bei mir nie elegant und häufig mit Code-Wiederholungen verbunden, was schon mal ein Zeichen schlechten Programmierens ist. Ist mir aber egal. Hauptsache, es läuft irgendwie.

    Im übrigen ist das Hauptproblem nicht Lua, sondern das Visionaire-Objektmodell, was man tatsächlich verinnerlichen sollte, wovon ich aber noch weit, weit entfernt bin. Ich schaue in die Data-structure-Liste oder ins Scripting und überlege, was wohl die sinnvollste Lösung zum Problem wäre. Ich erfinde das Rad immer wieder neu, denn zu Lua gibt es genügend Quellen, zum Vis-Objektmodell aber praktisch nur das Wiki im Forum und zudem noch auf Englisch. Da hilft nur: viel selber rumtesten.

    Meine Anmerkungen zu weiteren Bugs habe ich hier reingeschrieben, weil das der einzige Thread hier ist, der Bugs zu RC2 auf Deutsch beschreibt. Sorry dafür.

    Den neuen Menübreich "Sound" ganz rechts oben auf der Menüleiste hab ich auch noch gar nicht ausprobiert; ich weiß nicht mal, ob der überhaupt schon eine Funktion hat... wink

    Thread Captain

    1093 Posts

  • #17, by BroeselMonday, 28. August 2017, 21:39 4 years ago
    Alles klar....

    Mit meinem eingerosteten Oldschool-English mühe ich mich da schon herum :-)

     Aber Dank sebastians Videos kommt man schon weit..

    Außerdem habe ich in diesem Forum bisher nichts zu klagen:
    "Bei uns werden sie geholfen" scheint hier schon zuzutreffen.

    see you

    Newbie

    27 Posts

  • #18, by SimonSMonday, 28. August 2017, 21:40 4 years ago
    So kurz nochmal ein paar Antworten, nachdem ich das Wochenende (ausnahmsweise) mal nichts gemacht hab.

    @Broesel: Die Verknüpfungen sind falsch benannt, in der Free-Version hab ich tatsächlich noch RC0 stehen. Wenn da nichts mehr dran steht merke ich das auch nicht mehr.

    Die Balance kann nur für Monosounds geändert werden, nicht für Stereosounds. Wer das also nutzen will, muss da Mono hinpacken.

    Was ist jetzt mit "die Lautstärkeregelung reagiert nicht fein" gemeint ?

    @Machtnix: Die Animationsbilder sind zu groß für den reservierten Speicher, Strg+E öffnet den Explorer, dann Game / GamePicBufferSize, da die Größe in KB eingeben. Außerdem ist 24MB pro Bild ziemlich viel, dann ist das schon ein 2500x2500 Bild, das ist viel für ne Animation.

    Der Text in der Logansicht kann kopiert werden mit Markieren und Strg+C, ansonsten kann mit Strg+Mausrad auch die Text-Größe ändern.

    Thread Captain

    1460 Posts

  • #19, by BroeselMonday, 28. August 2017, 22:05 4 years ago
    Was ist jetzt mit "die Lautstärkeregelung reagiert nicht fein" gemeint ?


    Ich habe eben noch einmal versucht, die Soundlautstärke für die Kulisse, über die kleinen up/down-Pfeile zu regeln..Reagiert meistens nicht...Ergo gebe ich Zahlenwerte ein:
    Bis 30 gibt es hörbar einen Veränderung der Lautstärke... aber von 40 bis 100 ist alles diesselbe Lautstärke.

    Win10 Home / 64bit

    Newbie

    27 Posts

  • #20, by MachtnixTuesday, 29. August 2017, 00:27 4 years ago

    @Machtnix: Die Animationsbilder sind zu groß für den reservierten Speicher, Strg+E öffnet den Explorer, dann Game / GamePicBufferSize, da die Größe in KB eingeben. Außerdem ist 24MB pro Bild ziemlich viel, dann ist das schon ein 2500x2500 Bild, das ist viel für ne Animation.

    Der Text in der Logansicht kann kopiert werden mit Markieren und Strg+C, ansonsten kann mit Strg+Mausrad auch die Text-Größe ändern.

    Vielen Dank für die Info.

    Ich habe das Spiel (das Labyrinth, das ich hier schon mal vorgestellt hatte) einfach in RC2 geöffnet und neu abgespeichert. Da in 4.2.5 alles ordnungsgemäß funktioniert, bin ich davon ausgegangen, dass es das auch in RC2 tun würde. Offensichtlich arbeitet RC2 intern jedoch anders - und in diesem Fall leider nicht besser, sondern gar nicht. Ein in 4.2.5 erstelltes Spiel läuft nämlich problemlos mit allen Animationen, trotz der großen Grafik. Den Grafik-Cache kann ich maximal auf 500 MB erhöhen, was in 4.2.5 auch nötig war. Hier scheint das nichts zu nutzen.

    Nun geht der Trend ja ohnehin zu HD-Spielen ( 1920 Pixel Breite für die heute übliche Standardbildgröße finde ich nicht wirklich klein!), so dass größere Animationen naturgemäß jetzt doch öfter vorkommen werden. Also wäre RC2 noch nicht ausgereift genug für die Zukunft, oder?
    Meine Animation ist deshalb so groß, weil sie die ganze Kulissen-Fläche ausfüllt, umfasst aber nur 50 Bilder und besteht nur aus einigen Elementen in Gelb und ist ansonsten transparent. Ja, es stimmt, es ist eine ziemlich große Animation, aber selbst mit pngs hatte die 4.2.5 keinerlei Probleme (nur mein alter XP-Rechner stotterte ein bisschen...).

    Es gibt außerdem andere, kleinere Abweichungen im Aktionsablauf usw. Deshalb benutze ich die aktuelle Version erstmal nicht;  für ein neu angelegtes Spiel vielleicht.

    Anstelle des Kommandozeileneditors werde ich vielleicht den "Snaketail" mal ausprobieren. Groß- und kleinskalieren der Schrift geht zwar, aber dann kann ich leider nichts mehr lesen... wink

    Das mit dem Mono-Sound und der Balance hört sich (leider...) plausibel an. Kein Wunder, dass es bei mir auch in Lua nicht geklappt hat - ich hatte natürlich immer nur Stereo-Sounds...

    Machtnix


    Thread Captain

    1093 Posts