Send to Position - Problem (SOLVED)

  • #1, by elecWednesday, 24. May 2017, 13:20 3 years ago
    Hello everybody!

    So i got this really odd problem. I use the Action "Send Person to position" quite alot, but in a few parts of the game the command gets ignored. But sometimes it works perfectly fine. The Point where i want to send the Person is reachable via the waysystem.
    This Situation is in a cutscene, i used the "Hide/Show Cursor" instead of the Cutscene command so it's not skippable.

    Forum Fan

    109 Posts


  • #2, by joemidWednesday, 24. May 2017, 15:18 3 years ago
    Maybe add a Pause before?  Or after?  10ms?  Are you checking "Wait until character reaches destination"?  Maybe uncheck that, use a short pause action, and then a wait until character reaches dest action?

    Newbie

    87 Posts

  • #3, by elecWednesday, 24. May 2017, 16:04 3 years ago
    Okay, i tried that and some other things and i think the Problem is, the "wait until character reaches destination" doesnt work right, it just doesnt wait. the character starts to walk and suddenly everything else afterwards goes on (even with "wait til char reaches destination" checked)

    Forum Fan

    109 Posts

  • #4, by brut69Wednesday, 24. May 2017, 16:07 3 years ago
    I had the same problem. The solution was the way-points as sometimes the character does not know how to reach the destination and it stops. 
    To fix it you need to do one of the following:
    A- To reach destination C instead of going A--> C , do A--> B --> C . Breaking up half the way and making it easier for the character to follow the path fixed most of the issues
    B- Create better waypoints. Are you using RIGHT Click to join the waypoints? This helps ALOT with them. Add a few more (preferebly clear your previous ones) and break most of the waypoints in half by adding more of them 

    Great Poster

    263 Posts

  • #5, by elecWednesday, 24. May 2017, 17:12 3 years ago
    Sadly, both Options didnt work out for me. The Character still starts moving, but nearly instantly stops and everything else moves on.

    Forum Fan

    109 Posts

  • #6, by brut69Wednesday, 24. May 2017, 17:26 3 years ago
    Can you post a print screen of the "script" or produre that is giving you problems?

    Great Poster

    263 Posts

  • #7, by elecWednesday, 24. May 2017, 23:28 3 years ago
    Well, the Problem i got is that my Visionaire is in German, so i dont know if it would help you, do you understand German or should i try to translate it?

    Forum Fan

    109 Posts

  • #8, by sebastianWednesday, 24. May 2017, 23:50 3 years ago
    Well, the Problem i got is that my Visionaire is in German, so i dont know if it would help you, do you understand German or should i try to translate it?

    you could change the editors language to english, make the screenshots and change it back wink

    Thread Captain

    2337 Posts

  • #9, by elecWednesday, 24. May 2017, 23:57 3 years ago
    So that "hide cursor -> hide cursor" thing in the right one did i change already, but thats not the problem, this are the 2 worst appearances of the problem, though there are 2 or 3 more

    Forum Fan

    109 Posts

  • #10, by sebastianThursday, 25. May 2017, 12:47 3 years ago
    maybe the problem are the weird waypoints you set there.
    Do they have a reason why they are spreading over the ground like that? I only see one obstacle there (the cauldron)...

    Thread Captain

    2337 Posts

  • #11, by AlexThursday, 25. May 2017, 13:29 3 years ago
    Hi,

    make sure to send the character to a destination inside your way borders. I can't really tell from your screenshot. If the destination is outside the way borders the character will be sent to the nearest way point. And as sebastian mentioned your waypoints  look a little bit weird.

    If possible the characters walks directly to the destination. In case there are any obstacles the character walks to the closest waypoint, walks along the waysystem and from the last way point to the destination.

    Great Poster

    378 Posts

Write post