Problem with full pixel art [Solved]

  • #1, by TinTinFriday, 23. December 2016, 17:56 4 years ago
    Hi

    My game is full pixel art and actually I don't want any blur effect . But my character have blur with scale character or not in the game .
    I check 'activate pixel effect' in game properties too .
    Where is my wrong ?
     

    Forum Fan

    193 Posts


  • #2, by afrlmeFriday, 23. December 2016, 18:58 4 years ago
    Hi

    My game is full pixel art and actually I don't want any blur effect . But my character have blur with scale character or not in the game .
    I check 'activate pixel effect' in game properties too .
    Where is my wrong ?
     
    Did you set magnification & minification in the game (cog) tab to "nearest neighbour"? You should also use a low default resolution if you aren't already doing so. 320x240 or 640x480 or something.

    Imperator

    6862 Posts

  • #3, by TinTinSaturday, 24. December 2016, 07:20 4 years ago

    Did you set magnification & minification in the game (cog) tab to "nearest neighbour"? You should also use a low default resolution if you aren't already doing so. 320x240 or 640x480 or something.

    Where is "nearst neghbour" option ? I couldn't find it. Do you mean config.ini after build ? I changed resolution to Auto/Game/Desktop and I get more blur .
    Important things:
    Background is OK and it's full pixel art but Character have some blur in edges and more in body colors.

    My resolution is 640X360

    Forum Fan

    193 Posts

  • #4, by sebastianSaturday, 24. December 2016, 08:44 4 years ago
    all in the game properties tab inside the engine. 

    Thread Captain

    2340 Posts

  • #5, by TinTinSaturday, 24. December 2016, 09:15 4 years ago
    Wow. Thanks Sebastian . I find it . I'm really dizzy .
    Problem solved

    Thanks for help guys.

    Forum Fan

    193 Posts

  • #6, by afrlmeSaturday, 24. December 2016, 10:45 4 years ago
    Wow. Thanks Sebastian . I find it . I'm really dizzy .
    Problem solved

    Thanks for help guys.
    haha, I guess I should have attached a screenshot. Edit the title of this thread & mark as solved please, cheers. wink

    Imperator

    6862 Posts

  • #7, by TinTinMonday, 26. December 2016, 18:05 4 years ago
    Sorry to post again

    It seems VS can't make pixel perfect for scale pixel art characters. Is any option in VS for don't distort character in scale up ?
    I don't want any leanear or blur option.

    Forum Fan

    193 Posts

  • #8, by sebastianMonday, 26. December 2016, 20:17 4 years ago
    you have to use neearest neighbor for Mini/Magnification filter and "activate pixel effect" in the game settings. This will provide non-blurry images. The problem may is that your screen resolution is not a multiple of your game resolution and by that the game gets streched (?) 

    Thread Captain

    2340 Posts

  • #9, by TinTinTuesday, 27. December 2016, 07:02 4 years ago
    Yes , all options that you mention is enable . My problem is with scale character when I use larger or slower than normal . I know is it normal situation when we use pixel art we have distortion character in scale . But some engines like AGS improve it better than VS .

    Anyway I must careful for adjust size in depth and use 2x in way points for get best result (I think so ).

    Maybe I want change 640X360 to 1280X720 ( 2X HD)

    Forum Fan

    193 Posts

Write post