Possible bug in animation editing?

  • #1, by XerilonSunday, 31. July 2016, 18:51 4 years ago
    I am using 4.0 at the moment, and discovered that when I choose a frame with left click it seems normal , but when I right click it to choose editing, the selected frame jumps back 116 frames in relation no matter what frame I choose, thus I can not edit the frame I want. The animation has 220 frames, and the error on selection starts at frame 115 and forwards.

    I have tried restarting the project, and deleting the animation to set it up again, but the weirdness is still there.
    The "bug" does not appear at other animations in other scenes.

    Newbie

    37 Posts


  • #2, by afrlmeSunday, 31. July 2016, 19:20 4 years ago
    What do you mean right click to edit it? Are you using windows or mac as right clicking on a frame is working ok for me. You do know you can left click to select a frame then click on the edit frame icon on the toolbar? There's no need to right click it.

    By the way, the animation sounds overly big to me. Does it play smoothly? I reckon people on lower spec machines will have loading issues due to the large amount of frames.

    Imperator

    6812 Posts

  • #3, by XerilonSunday, 31. July 2016, 20:02 4 years ago
    Yeah, I'm considering packing it into a video file in the future, but still, it plays smooth smile...

    Using windows 10 and by right clicking, I mean you right click in the "timeline" to bring up a small dropdown menu where you can edit the frame i.e. put actions or sounds into it etc..

    On the added image I had first left clicked frame 207 and then right clicked it to bring up the menu, and on the "right click" the black dot jumped back to frame 62. It's pretty strange..

    Newbie

    37 Posts

  • #4, by afrlmeSunday, 31. July 2016, 20:41 4 years ago
    Maybe too many frames for wxWidgets to handle correctly? Use the edit animation frame icon on the toolbar. It's the one to the right of the remove frame icon ( - ).

    Imperator

    6812 Posts

  • #5, by XerilonSunday, 31. July 2016, 21:09 4 years ago
    Aha, that worked!!
    Thank you very much! smile

    Newbie

    37 Posts

  • #6, by afrlmeSunday, 31. July 2016, 21:11 4 years ago
    No problem. wink

    Imperator

    6812 Posts

Write post