"Play Sound" is broken?

  • #1, by fulviovMonday, 07. March 2016, 01:11 4 years ago
    I seem to be having problems with the "Play Sound" action.
    The files are .ogg encoded, and they play just fine when I set them as background music.
    I have tried to put a "wait until sound is finished" action after it, and the sequence of actions seems to wait for the sound to end, but it doesn't play.
    Am I doing anything wrong? I am on a Mac, by the way.
    Thanks in advance!

    Forum Fan

    119 Posts


  • #2, by sebastianMonday, 07. March 2016, 07:32 4 years ago
    Is the sound volume inside the game loud enough?

    Thread Captain

    2337 Posts

  • #3, by fulviovMonday, 07. March 2016, 09:22 4 years ago
    Volume is set to the max, also I hear the background music just fine, it's just the "play sound" action that doesn't seem to work

    Forum Fan

    119 Posts

  • #4, by sebastianMonday, 07. March 2016, 10:13 4 years ago
    I only mean the sound volume independend from music. You are able to turn sounds down in vs. So what i assume if you dont hear any sounds, but music that this setting is active...

    Thread Captain

    2337 Posts

  • #5, by fulviovMonday, 07. March 2016, 11:16 4 years ago
    I see all volumes turned up to the max, even the play sound volume ... not sure if there is any other volume control around I am unaware of? Btw the sounds work just fine if I click play from the editor, so I assume Visionaire can successfully decode them

    Forum Fan

    119 Posts

  • #6, by sebastianMonday, 07. March 2016, 11:48 4 years ago
    Hmmm.. Can you post your config.ini?

    Thread Captain

    2337 Posts

  • #7, by fulviovMonday, 07. March 2016, 12:01 4 years ago
    Pretty regular...

    FILE = kyle.vis
    #
    # FULLSCREEN = {yes|no}
    # yes - starts the game in fullscreen
    # no - starts the game in a window
    FULLSCREEN = yes
    #
    # RESOLUTION = {Auto|Desktop|Game}
    # Auto - wide-screen support is activated if a wide-screen display is detected
    # Desktop - current desktop resolution is used when game is started in full screen mode
    # Game - game is initialized with the resolution specified in the game
    RESOLUTION = desktop
    #
    # INTRO = {yes|no}
    # yes - Show the intro movie on start-up
    # no - Don't show the intro movie
    #
    # LANGUAGE = {German|English|...}
    #
    # LOGLEVEL = {Info|Warning|Error}
    LOGLEVEL = error
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22

    Forum Fan

    119 Posts

  • #8, by sebastianMonday, 07. March 2016, 17:49 4 years ago
    Hm ok. There are no options saved about the sound. What about your player options in the visionaire settings?

    Thread Captain

    2337 Posts

  • #9, by afrlmeMonday, 07. March 2016, 19:42 4 years ago
    Is that the config file taken from your exported games root folder? If so then that is only a temporary config file that is used for the first time your game is run. The actual file you want will be somewhere in c:/users/username/appdata/local/... it gets created after the first time your game is run. If you have changed the volume settings in an action on game launch or something then it is possible that it is reading the sound settings directly from the config.ini. Volume levels are automatically written to & read from the config file without you having to access the file via Lua script.

    Imperator

    6842 Posts

  • #10, by MachtnixMonday, 07. March 2016, 19:45 4 years ago
    You can try to use a wav or a mp3-file instead to check the correct sound function and effect. If they play properly the ogg must be damaged. Often it's useful to convert an ogg-file into an ogg-file (with a converting tool running on your system), because some codecs are not ok.
    Other way is to write a little Lua script with increasing all sound volumes up to 100%. Sometimes there are forgotten hidden sound settings...

    Thread Captain

    1087 Posts

  • #11, by fulviovMonday, 07. March 2016, 21:37 4 years ago
    I have found another 2 .ini files within the Visionaire libraries, this is one:

    MusicVolume = 100
    SoundVolume = 100
    SpeechVolume = 100
    MovieVolume = 100
    GlobalVolume = 100
    1
    2
    3
    4
    5
    6


    and this is the other:

    [General]
    ShowSelectionLabel=1
    LastStartupSelection=3
    TextLanguage=Italiano
    UsedActionParts=45/1,100/1,94/1
    LanguageFile=language.2.english.xml
    AutoZoomPaintBox=1
    ZoomStepSizeDouble=0
    ZoomStepSize=10
    ScrollStepSize=20
    DirectionStepSize=45
    AutoSetObjectCenter=1
    AutoCreateTextActionPart=0
    ShowPathAsToolTip=0
    Debug=0
    ActiveColor1=FFFFFF
    ActiveColor2=000000
    InactiveColor1=808080
    InactiveColor2=000000
    PointColor=FFFFFF
    PlayerFullscreen=0
    PlayerSupportWidescreen=1
    PlayerNoSound=0
    PlayerNoVideos=0
    PlayerLogLevel=Info
    ShowActionPartSelector=0
    RegisteredVersion=5
    Language=english
    [MainWindow]
    UseTableToolbar=1
    [LastOpened]
    File0=/Users/fulvio/Desktop/Kyle/Kyle.ved
    File1=/Users/fulvio/Desktop/visionaire_3d/test3d.ved
    File2=/Users/fulvio/Desktop/visionaire_3d/Untitled.ved
    [VisObjListCtrl]
    listCtrl_eLanguages=32
    ShowCopyPasteIcons=1
    ShowRenameIcon=1
    ShowDuplicateIcon=1
    [Splitter]
    RightSplitterH_eFonts=484
    RightSplitterH_eScenes=563
    SceneObjectsSplitterV=226
    MainSplitterV_eTexts=350
    MainSplitterV_eScenes=203
    ObjectAnimationsSplitterV=200
    [RegisterInfo]
    UserNameVis4=Fulvio
    SerialKeyVis4=<hidden>
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50


    I also tried wavs and mp3s, which not only do not work, but make the editor crash as well.
    Oh, and I have also just tried .opus, which same as .ogg works fine in the editor preview but no sound output in game.
    Really not sure what I am doing wrong...

    Forum Fan

    119 Posts

Write post