Particles and save game containers hidden behind objects

  • #1, by tom-hardwidgeFriday, 18. September, 18:30 A month ago
    Hi,

    On my save/load menu I've got some animated background layers (moving clouds etc.) but they are covering up the save/load game containers. Is there any way to change the z-levels of the save games so they appear on the top of the other objects in the menu?

    Also, I have a similar problem with my rain particle system. I can't seem to get it to sit above the objects in the scene, it's always in the background.

    Thanks.
    Tom

    Newbie

    28 Posts


  • #2, by afrlmeFriday, 18. September, 20:52 A month ago
    Menu scenes only have 2 (or 3 if you count the scene background image) object centers (z-index). 0 which is the save game slot thumbnail layer, & 1 which is everything above.

    Before 4.x everything used to get drawn below save game thumbnails, but I wanted the option to add images/animations above save game thumbnails so that we could create fancy borders/frames, etc for them. Ideally it would be nice though if there was an additional object center available so that we could draw things below save game thumbnails.

    Imperator

    6846 Posts

  • #3, by tom-hardwidgeFriday, 18. September, 22:40 A month ago
    Ah ok. I'll animate the background image instead.
    Is that why the particles are appearing beneath the objects in the menu too?

    Newbie

    28 Posts

  • #4, by tom-hardwidgeFriday, 18. September, 23:20 A month ago
    I've had a go at using the masking plugin on the objects over the top of the save game slots, but it's just showing black through the mask where the save games should be. Thought it was worth a try, any ideas on how I could make them display in this way?

    Thanks.

    Newbie

    28 Posts

  • #5, by afrlmeSaturday, 19. September, 01:10 A month ago
    er... the draw order is based on the order you list the scene objects, meaning that if you assigned a particle to a scene object then the draw order is based on the position of the linked object in the scene list.

    Imperator

    6846 Posts

  • #6, by tom-hardwidgeSaturday, 19. September, 09:11 A month ago
    Weirdly I've not been able to find out how to attach a particle system to an object. I'm guessing that I'm missing something obvious. Will try and figure it out!

    Let me know if you have any ideas about the save game slots appearing as black when masked.

    Thanks
    Tom 

    Newbie

    28 Posts

  • #7, by afrlmeSaturday, 19. September, 12:40 A month ago
    Don't know about the mask thing, sorry. As for particles, they are now assigned to scene objects via the components tab on the right side of the editor. Select a scene object, click on the components tab, create a new component, select particle system, then link to the particle you want to assign to the scene object.

    Imperator

    6846 Posts

  • #8, by tom-hardwidgeSaturday, 19. September, 23:34 A month ago
    Brilliant, that's sorted that issue for me. Thanks!

    It looks like the issue with the masking on the save/load screen is that the mask objects themselves aren't being hidden by the condition.

    I've just gone with a static background for now, but it would be great if the save/load screens supported more z-levels at some point to accommodate animated backgrounds smile

    Newbie

    28 Posts

  • #9, by afrlmeSunday, 20. September, 02:18 A month ago
    You can still technically add an animated background, but you would need to make cutouts where the save slots go. Adding animations to play in the empty save slots is also possible, but it's a bit more complicated as you would need to link a value to them so you can hide/show them based on the total amount of save games there are.

    Imperator

    6846 Posts

Write post