Object Polygon not Reset on Scene Re-enter

  • #1, by atrusThursday, 29. June 2017, 16:15 3 years ago
    Hi all,

    Noted the following issue:

    I'm using ObjectOffset to move an object to a new position in the scene. It works ok, i.e. object image and polygon are moved. I know that this is temporary and when you leave and re enter the scene, the object goes back to its original position, which is fine. However, while the image goes back to its original position, the polygon doesn't; it just stays in the moved position. I guess this is not the normal behaviour?

    If it's not clear, i will try to make a ved file to demonstrate.

    Forum Fan

    237 Posts


  • #2, by atrusSaturday, 01. July 2017, 13:03 3 years ago
    Hello all,

    Have created a .ved test file here:


    You may test as follows:

    1. Get the key and place it on the upper left hook. (It uses ObjectOffset)
    2. Click on left or right of scene to switch to a new temp scene.
    3. On the new temp scene, click on the letters to go back to the key scene.
    4. You will scene that the key image is back to original position, but the polygon is still on the hook!

    Rgrds

    Forum Fan

    237 Posts

  • #3, by ke4Saturday, 01. July 2017, 13:45 3 years ago
    I suppose it's a bug. Both should remain moved or on the original position. What happens if you reset the offset on the scene entry? To the original offset or to the changed based on a condition.

    Key Killer

    810 Posts

  • #4, by atrusSunday, 02. July 2017, 12:18 3 years ago
    Thanks ke4,

    Behaviour is the same, ObjectOffset itself works, but the reset is not working for the polygon.

    Forum Fan

    237 Posts

  • #5, by ke4Sunday, 02. July 2017, 12:22 3 years ago
    Then i suggest you to create a duplicated version of the obejct on the new position and right after the movement hide the original object and show the duplicated one.

    Key Killer

    810 Posts

  • #6, by atrusSunday, 02. July 2017, 12:46 3 years ago
    Here's the problem:

    It is a puzzle which would need abt 1000 duplicate objects (32 positions with 32 posible combinations each) razz

    So we really need to get this ObjectOffset issue fixed i'm afraid.

    Forum Fan

    237 Posts

  • #7, by atrusTuesday, 04. July 2017, 12:43 3 years ago
    Hi guys,

    Any chance with this bug?

    Thanks

    Forum Fan

    237 Posts

  • #8, by SimonSWednesday, 05. July 2017, 13:19 3 years ago
    I have found it and fixed it, next version.

    Thread Captain

    1380 Posts

  • #9, by atrusWednesday, 05. July 2017, 17:40 3 years ago
    Fantastic, u r the man, thanks!!

    Forum Fan

    237 Posts

Write post