Nervous about Installing Updates

  • #1, by ozzie-daveThursday, 21. June 2018, 08:07 2 years ago
    Firstly I would like to say how much I like Visionaire Studio v5.0.3. I have completed my first
    Adventure Game, and enjoyed making it in this excellent software programme.
    BUT I am always nervous about installing updates, as my experience has tought me that most times it disrupts the free flow of the previous version. 
    Could any Forum Members advise me if the latest upgrade of Visionaire Studio will integrate
    into my v5.0.3 with very few problems.
    Also how easy is it to go back to the old version, if the latest upgrade causes problems.
    Many Thanks

    Newbie

    22 Posts


  • #2, by NigecThursday, 21. June 2018, 09:54 2 years ago
    IF your game is working fine and any fxes don't effect you I would continue with the version you are using and get your project finish then maybe look at updating for your next project.

    I've had a project monumentally screw up after an update.. so I would wait until I was doing something new smile

    Key Killer

    563 Posts

  • #3, by sebastianThursday, 21. June 2018, 10:25 2 years ago
    you cant return from a newer version back to an older. The editor will not open it anymore. Therefore make a backup of your project first and then Update /open your project with a newer Version of the editor.

    Normally it should work just fine as mist things are either bugfixes or new features which were not implemented before and because of that not present in your project. 

    The main things which could break are lua based scripts or some behaviours which were changed (like lipsync animations from the last two builds, where the animation now has an extra frame and you would need to manually add that after the update.) 

    Mostly you are just fine if your project based on only action parts. 

    kind regards 
    Sebastian 

    Thread Captain

    2337 Posts

  • #4, by SimonSThursday, 21. June 2018, 11:21 2 years ago
    If you like your version, you can keep it. - Obama

    Just remember two things:

    - If you have a problem then, we might ask you to update your version.
    - You might want some features that are added later and find that there are bugs, that only you have, if nobody tells me about them, I can't fix them.

    You also manually downgrade veds by removing the new fields.

    Thread Captain

    1368 Posts

Write post