Clicking on the NPC won't start dialogue

  • #1, by bumblebeetfSaturday, 05. June, 21:28 A week ago
    When I click on the NPC it won't start the dialoge. Any ideas what I'm doing wrong? Thanks in advance.

    Newbie

    4 Posts


  • #2, by afrlmeSunday, 06. June, 00:29 A week ago
    Hmm, out of curiosity is there any reason why you are using Visionaire Studio 4.25? The latest version is 5.1.6.

    In regards to the dialog not starting, I believe the action you have created an execute command at destination type action. Can your playable character reach the npc character/or the interaction position you specified on the npc properties tab? If they can't then the action won't be executed.

    Imperator

    6979 Posts

  • #3, by bumblebeetfSunday, 06. June, 19:08 A week ago
    I didn't realise there was a new version available. I will check that out.


    I think you might be on to something, but unfortuantely I"m extremely tired after working a long shift and just managed to really mess up my project. I'm going to restore a previous version and try again tomorrow. 

    My controllable player was able to walk right up to the NPC, but your response reminded me that sometimes he would walk up to the NPC even when I wouldn't expect it (the npc is near the end of a waypoint). I'm going to try removing the waypoint and see what that does. When I click on the NPC maybe the player is just going to the end of the waypoint rather than to the NPC.

    Thanks for taking the time to read my post and helping me.

    Newbie

    4 Posts

  • #4, by bumblebeetfWednesday, 09. June, 21:18 A week ago
    I think it maybe my mouse interface is part of the problem. It acts as though the NPC I click on isn't there. My character will walk right through the NPC when i click on him. I was trying to set up the one cursor to walk, talk, and take. Is this possible?

    Newbie

    4 Posts

  • #5, by afrlmeWednesday, 09. June, 21:40 A week ago
    Ah ok, try moving your mouse interface to the top of the list. Make sure you set the command button you created as the standard command in the properties section for that interface & also make sure that none of the buttons in your inventory interface are command type buttons.

    Imperator

    6979 Posts

  • #6, by bumblebeetfWednesday, 09. June, 22:03 A week ago
    grin grin grin grin grin grin grin grin grin  THANK YOU!!!!! grin grin grin grin grin grin
    It worked!!!! grin grin grin grin

    Newbie

    4 Posts

Write post