change animation index of character problems

  • #1, by sebastianSunday, 25. June 2017, 23:12 3 years ago
    Aye there folks,

    im struggling a bit with the animation index action part.
    I have 2 talk animations for each direction and liked to change it so the character could look angry/amused/etc. But i cant see the change... What am i doing wrong here?



    Wiki says:
    Change character animation index
    Changes the animation index of a character (default is 0 when the game is started). This index is used for talk-, random- and stand-animations. If more than 1 animation exists for a direction then this index decides which animation is shown.

    Example: A character has 8 talk animations, 2 for each direction (0, 90, 180, 270 degrees). If the index is 0 then the first of the two animations (for a direction) is shown. If the index is 1 then the second animation is shown.

    With this index it is possible to have different animations (e.g. talking friendly / neutral / angry) without changing the complete outfit.
    hope someone can help =)


    Thread Captain

    2340 Posts


  • #2, by sebastianSunday, 25. June 2017, 23:28 3 years ago
    could it be that it has something to do with missing animations for other directions?
    i made now 2x right and 2x left (mirrored). The animations for right work now. the animations for left not. Seems like "the last animations" in the list have this problem... (bug?)

    Thread Captain

    2340 Posts

  • #3, by afrlmeSunday, 25. June 2017, 23:36 3 years ago
    could it be that it has something to do with missing animations for other directions?
    i made now 2x right and 2x left (mirrored). The animations for right work now. the animations for left not. Seems like "the last animations" in the list have this problem... (bug?)
    I've had issues with using character animation index myself as well. It works, but not always. Maybe buggy?

    Imperator

    6862 Posts

  • #4, by esmeraldaMonday, 26. June 2017, 11:57 3 years ago
    I have tried to get the animation index working since 3.7 - without luck. The engine seems to change the index / images randomly. I haven't tried in Vis 5 yet.
    If you find a way to reliable use the animation index, please let me know.

    Great Poster

    396 Posts

Write post