VS 4.2.5 build 1185 Build Game issues

  • #1, by minibigsSaturday, 12. December 2015, 19:26 4 years ago
    When I build a game using the "Store game objects in the output file" option, then run the resulting ".exe" , I get this error:

    init failed. could not load game.
    There is no game file or the game file is corrupted.

    If you take the "Store game objects in the game object output file" option & define an object output file it works OK.

    ====================================================

    My screen resolution is 1920 X 1080. My scenes & menus are all 1920 X 1080.
    I run the built game with "FULLSCREEN=yes" set in the config file.

    If I set "RESOLUTION=Auto" or "RESOLUTION=Desktop" in the config file, the game plays in a window that I would estimate is about 480 X 270.
    If I set "RESOLUTION=Game" it plays in full 1920 X 1080.

    What I was hoping to do was to scale my resolution in the build tool to 1/4 size to keep my game a reasonable size, then run it "RESOLUTION=Desktop" to scale it back up.

    Newbie

    79 Posts


  • #2, by afrlmeSaturday, 12. December 2015, 20:02 4 years ago
    I don't think it really works like that. Also the scale feature in the build section is buggy. It doesn't scale the object interaction polygons correctly & there are various other issues too.

    Resolution = desktop / auto just scales the game up to whatever resolution your monitor is set to. auto will also automatically scale in proportion (will add black bands horizontally or vertically, if needed).

    As for the issue, it could be to do with how you exported your game. It's best to export things into individual files or an output file for each type, the first method is better though as it allows you to release updates without the players having to re-download your entire game each time.

    Imperator

    6805 Posts

  • #3, by minibigsSaturday, 12. December 2015, 20:49 4 years ago
    Ta, I will leave the scaling feature well alone then.

    Re the issue....
    Yes, it is to do with the game export method ... It's not an issue for me, I use individual files normally.

    I was just pointing out that the option to build a combined file doesn't work, at least not on anything I've tried.


    "Resolution = desktop / auto just scales the game up to whatever resolution your monitor is set to. auto will also automatically scale in proportion (will add black bands horizontally or vertically, if needed)."

    Your explanation there is what I want it to do... i.e. scale the game up to the monitor resolution... as far as I can see that isn't happening though, as it plays the game in a quarter sized window not in full screen at the monitor resolution (1920 X 1080).

    My reading would be that if you wrote a game using scenes of say 1024 X 768 then ran it full screen using "Resolution=Auto" on a monitor set to 1920 X 1080, the engine would "stretch" the output to fit the screen display & fill in the edges with black space as needed for widescreens. Is that not the case then?

    If that is the case, why doesn't it run my game at 1920 X 1080, but at (what I would guess as) 1/4 of that?

    If not, what's the feature for?

    Newbie

    79 Posts

  • #4, by afrlmeSaturday, 12. December 2015, 21:35 4 years ago
    This is with an exported build that you scaled down in the export options or an exported build in general?

    If you are running it in fullscreen mode & with resolution = desktop or auto then it should automatically scale the game to the window resolution. If the game is being run in window mode then it will automatically scale the window to the game resolution unless you include...

    resizeable = yes
    resolution = 1024x720 (whatever you want to force window to).

    Fullscreen mode is usually automatic & will not force resolution, except with the GAME option.

    I don't understand why it should run quarter size, unless you are talking about creating a game that is a larger resolution than the actual artwork (backgrounds / sprites) of your game. The backgrounds should be at least the same size as your games default resolution. Backgrounds larger than the default resolution will automatically become scrollable scenes. Backgrounds smaller than the default resolution will not display correctly. The engine does not scale the images itself to fit the game resolution it only scales the surface area (backgrounds, sprites, texts, interaction polygons) to the active monitors resolution in fullscreen mode.

    Imperator

    6805 Posts

  • #5, by minibigsSaturday, 12. December 2015, 22:16 4 years ago
    OK, to simplify things:

    I have just created a new project based on the supplied minimal configuration.
    In the editor's game properties screen the resolution is 1024 X 768.

    I then did a build without modifying the supplied example at all.
    In the built config file we have:
    FULLSCREEN = yes
    RESOLUTION = desktop

    The screen resolution is 1920 X 1080 (50" HDMI TV, Intel HD graphics 4600, Windows 10 fresh install 3 days ago, drivers latest version).

    When the ".exe" file is run, the game plays in a section of my screen which I would estimate to be at the 1024 X 768 size. I don't think it's a window as such, just not scaling it to full screen size.
    Note the warning message that implies the screen has been switched out of 1920 X 1080 mode.

    Newbie

    79 Posts

  • #6, by afrlmeSaturday, 12. December 2015, 22:35 4 years ago
    Hmm... sorry I can't help you there. TV + 50". Maybe something in the tv settings is forcing the resolution change. The only thing I can tell you is native screen size for 1080p is 23" monitor, but you said it's a tv, so could be something to do with that, the graphics card or maybe the latest build of Visionaire Studio.

    Imperator

    6805 Posts

  • #7, by minibigsSaturday, 12. December 2015, 23:31 4 years ago
    Thanks.

    I copied it to a laptop with an Intel display adapter using it's built in monitor running native at 1366 X 768 & can report the following:

    - FULLSCREEN= Auto/Desktop/Game settings all work as expected, so the issue must be with my graphics card and /or TV rather than this VS build.

    - If running FULLSCREEN=no it runs in a window.
    However,with resizable=yes the window is not resizable & RESOLUTION=forced value (e.g. RESOLUTION=800X600) is ignored, the resolution does not change.



    Newbie

    79 Posts

  • #8, by afrlmeSaturday, 12. December 2015, 23:51 4 years ago
    It's Resizeable, you missed an E out. Anyway... here is a config file I created for someone else. Please ignore the scale factor bit as that is taken care of by a read / write config ini script I custom wrote for their game & thus will not work.
    File = data.vis
    #
    # Fullscreen = {Yes|No}
    # Yes: starts the game in fullscreen
    # No: starts the game in a window
    Fullscreen = No
    #
    # Resolution = {Auto|400x225|800x450}
    # Auto: wide-screen support is activated if a wide-screen display is detected
    # Desktop: current desktop resolution is used when game is started in full screen mode
    # Custom: enter a custom value eg: Resolution = 1920x1080
    Resolution = 400x225
    #
    # ScaleFactor= {1|2}
    # 1: 1x scale factor = 1:1 scale ratio; the way the game is meant to be played
    # 2: 2x scale factor = 2:1 scale ratio; for people who like to supersize
    ScaleFactor = 1
    #
    # Resizeable = {Yes|No}
    # Yes: window can be resized in window mode
    # No: window size is fixed to game default resolution in window mode
    Resizeable = Yes
    #
    # Language = {English|Italian}
    # this will display subtitles in the specified language
    Language = English
    #
    # LogLevel = {Info|Warning|Error}
    LogLevel = Error
    #
    # MusicVolume|SoundVolume|SpeechVolume|MovieVolume|GlobalVolume = int value {0-100}
    MusicVolume = 75
    SoundVolume = 100
    SpeechVolume = 100
    MovieVolume = 100
    GlobalVolume = 100
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37

    ... what the resizeable option does is allow the player of your game to resize the window manually, but it will also allow you to force specific resolutions on game launch providing fullscreen = no. Fullscreen will always force the game to scale to the available surface area of your active monitor. Auto option is just force proportional scaling if it's needed.

    Imperator

    6805 Posts

  • #9, by minibigsSunday, 13. December 2015, 00:23 4 years ago
    Funnily enough, when I added the extra "e" it all works perfectly in windowed mode.
    Consider me in the naughty corner for an hour & accept my apologies & thanks.

    I will have a play around over the next few days & see if I can work out why my particular combination of display adapter & TV will not re-scale the game in full-screen mode to the desktop resolution. I can't see it at the moment as the TV display works at 1920 X 1080, the same as the display adapter.
    Regards,
    Steve

    Newbie

    79 Posts

  • #10, by minibigsFriday, 18. December 2015, 13:02 4 years ago
    Well, just to round this one off. I had not been able to get my set up working full screen on my 50" TV as above, whatever I do.

    However, last night Windows 10 auto update installed:
    Cumulative Update for Windows 10 Version 1511 for x64-based Systems (KB3124200)

    It now all works perfectly, so it must have been Windows /Driver related.

    Newbie

    79 Posts

Write post