Visionaire Studio Bugfix Update 5.0.6

  • #1, by SimonSWednesday, 20. June, 21:58 6 months ago
    Hi there,

    next update is here without much new, just a bunch of fixes .
    Full Version:
    Free Version:

    New things:
    - button visibility field (warning: is overriden by interface visibility, if the interface is faded), field is VButtonVisibility
    - breakpoints now get saved
    - globals preview in debugger

    Fixes:
    - lipsync frame H missing (X is now frame 9, not 8 as before)
    - elseif not working correctly if nested and else at the end
    - particle performance increased 
    - error while saving ved is not shown
    - combobox is offset if the page is scrolled
    - po export: duplicated texts are not combined if different sound
    - po export: animation frames not checked
    - coordinates display update error
    - changing firstframe/lastframe updates the animation immediately 
    - delete save: can't select 0
    - console filters out events 
    - console shows own lua errors
    - createevent creates double clicks at random
    - animation editor now highlights 1 5 10...

    Thread Captain

    1154 Posts


  • #2, by AFRLmeWednesday, 20. June, 22:55 6 months ago
    Cheers mate. wink

    P.S: didn't realize there was an issue with forcing the animation frames via Lua script.

    Imperator

    6380 Posts

  • #3, by esmeraldaThursday, 21. June, 08:55 6 months ago
    Thank you, SimonS!
    I was wondering why you cut the frame H in lipsyncing... and here it is.

    Could anybody please explain, what
     - breakpoints now get saved 
    means? What breakpoints?

    Great Poster

    304 Posts

  • #4, by AFRLmeThursday, 21. June, 11:13 6 months ago
    Thank you, SimonS!
    I was wondering why you cut the frame H in lipsyncing... and here it is.

    Could anybody please explain, what
     - breakpoints now get saved 
    means? What breakpoints?
    He mentioned something about them on the developer channel on the Discord server. I didn't even realize we could create them - I only figured out last night after a couple of minutes of messing around that you can create a red dot at the left side of a line of Lua script by clicking to the left side of the line number.


    I've never used them myself. I believe they are to be used with the debugger that was implemented a while back.


    Imperator

    6380 Posts

  • #5, by esmeraldaThursday, 21. June, 14:47 6 months ago
    Ah thank you. I have seen these dots appear when I clicked a bit too far on the left of the line, but never found out what they meant/do.

    Great Poster

    304 Posts

  • #6, by LebosteinFriday, 22. June, 10:11 6 months ago
    Thanks!

    What is the status of using animation files like Spine or DragonBones? Is this still experimental or has something changed?

    Key Killer

    582 Posts

  • #7, by LebosteinFriday, 22. June, 16:29 6 months ago
    In the font editor of the Windows version there seems a problem with the screen refresh. If I walk through my fonts an click one font after another then often I see more than one font on the screen...

    Key Killer

    582 Posts

  • #8, by MateuszFriday, 22. June, 20:32 6 months ago
    Where can I find 5.0.5 installer? I updated to 5.0.6 and my animations (both "scenic" and cursors went totally nuts, acting spasmatic for the lack of better word). I've tried downloading from forum post about 5.0.5 but for whatever reason links posted there allows me to either download RC 1, RC 2 and 5.0.6

    Newbie

    32 Posts

  • #9, by sebastianFriday, 22. June, 21:02 6 months ago
    In the font editor of the Windows version there seems a problem with the screen refresh. If I walk through my fonts an click one font after another then often I see more than one font on the screen...
    additionally to that i am not able to zoom in/out anymore in the fonts workspace
    Using macOS Sierra.
    Where can I find 5.0.5 installer? I updated to 5.0.6 and my animations (both "scenic" and cursors went totally nuts, acting spasmatic for the lack of better word). I've tried downloading from forum post about 5.0.5 but for whatever reason links posted there allows me to either download RC 1, RC 2 and 5.0.6
    seems to be a bug with the first frame in that animation that the individual pause doesnt get recognized. Was mentioned in the VS Discord this afternoon by other users already. 
    As a workaround you can add a new 1st frame with a minimal pause which should then get skipped and continue with frame 2 (old frame 1) just fine.

    Thread Captain

    2257 Posts

  • #10, by AFRLmeFriday, 22. June, 21:28 6 months ago
    Hopefully he can push out a hotfix for that soon, as it's one of the most annoying bugs so far seeing as animations are one of the main things you need to use for developing your games.

    & yes confirmed it's a bug. Also it doesn't matter what pause value you set as the first frame will currently change to the second frame after one system loop which is approx 16.6ms which is how fast the engine needs to loop for 60fps.

    Imperator

    6380 Posts

  • #11, by LebosteinSaturday, 23. June, 17:46 6 months ago
    In the font editor of the Windows version there seems a problem with the screen refresh. If I walk through my fonts an click one font after another then often I see more than one font on the screen...
    Same problem with Mac OS

    Key Killer

    582 Posts

Write post