Visionaire 5.0 - Unable to create Mac Build

  • #1, by tookipalookiSaturday, 03. June 2017, 17:07 3 years ago
    Hello! I've been managing to get by so far from reading everyones posts and tutorials (thankyou for these! grin) but this little problem is throwing me and I can't seem to solve it. It's likely something very simple, it feels like I'm missing something obvious. 

    I started this project in Visionaire 4 but I brought it into Visionaire 5 to learn in there.

    I can run out a Windows and a Linux build of the game just fine, but when creating a Mac build it isn't creating the zip file. I can see it starting to create it in the folder but it just quickly vanishes and tells me in the dialog box that it's made a zip, but I don't see one.

    I'm running on Windows 7.
    Thanks to anyone taking the time to read this.


    1 Posts

  • #2, by NigecSaturday, 03. June 2017, 18:49 3 years ago
    I'm getting the same.. it appears to download the player but there's no sign of it

    Key Killer

    558 Posts

  • #3, by MachtnixFriday, 09. June 2017, 17:45 3 years ago
    I can run out a Windows and a Linux build of the game just fine,
    How did you manage this? I have tried to make a running Linux game from 4.2.5 for days. The Vis player date build (Linux) and the start-file are from 16. Nov. 2016 (last download: yesterday), the other files are still from August 2015. I made the "start" executable and change all rights from all files to write and read. I put all files together into one folder. So it should start by clicking on "start", right? What did I wrong?


    Thread Captain

    1079 Posts

  • #4, by SimonSFriday, 09. June 2017, 18:48 3 years ago
    @tookipalooki: Seems I overlooked this thread. Problem is you currently need an icon (just use a quadratic png/webp) or it won't export. That is fixed in the next version.

    Thread Captain

    1352 Posts

  • #5, by SteronoFriday, 27. March, 21:44 4 months ago
    Hey guys!
    I followed all the instructions on how to create a Mac build on PC (downloaded the Mac Visionaire Player, copied it and pasted it in the "platform" folder of the Visionaire directory, selected an icon (read this in another thread) but I always get the error message:

    platform mac not available, player for this platform must be downloaded.

    Can somebody help me please? Thanks in advance!
    My version: 5.0.9.


    28 Posts

  • #6, by pietro-eccherSunday, 29. March, 21:36 4 months ago
    Same here, and I can add that it seems to download it (there is a progress bar that fills) then at the end the same message pops up (and the same happens with 5.0.10)

    I already tried running visEditor as admin with no luck.

    I assume that as it's written in other posts you will need a mac or a mac vm to build for mac.

    Can someone confirm that?

    Thank you


    29 Posts

  • #7, by SimonSSunday, 29. March, 21:46 4 months ago
    Please wait til I have finished the update as I wrote before. Then it will work again.

    Thread Captain

    1352 Posts

Write post