Editor crashes in Virtualbox

  • #1, by htw8849Friday, 09. October 2015, 14:34 5 years ago
    Hi,

    I usually work under Linux running my Windows-Applications in a Win 8.1 virtual machine under Virtualbox.

    Now I'm trying to run the Visionaire Editor. Which starts perfectly fine and I'm also able to load the demo game examples.

    But as soon as I switch over to the scene or charackter interface the editor crashes - the crash log is only displayed for some microseconds and the it disappears.

    I assume that it might be related to some missing/not existing DirectX/OpenGL function - because I had that problem with an older graphic adapter (Intel 945M Chipset) on an old laptop.

    But then again, full 2D/3D-Support is enabled in the Virtualbox, which in theory should work with every 2D OpenGL/DirectX call.

    Did someone had the similar problems ? In case yes, how did he/she solve it ?
    How can I get hold of the crash log Visionaire/Windows is showing me for some milliseconds ?

    Many thanks for your help in advance.

    htw8849

    Newbie

    41 Posts


  • #2, by afrlmeFriday, 09. October 2015, 15:22 5 years ago
    The crash log won't really help you as it generates a dmp file. It will probably end up in c:/users/username/appdata/local/visionaire editor/

    If it did generate a zip file in the folder I mentioned then send the most recent one to David (BigStans) or SimonS as they may be able to figure out why it keeps on crashing for you.

    Imperator

    6842 Posts

  • #3, by htw8849Friday, 09. October 2015, 15:40 5 years ago
    Thanks for the quick answer - unfortunatly it did not generate the zip file, but in the directory I found the a "viseditor.log" file.

    And it seems that Visionaire Editor is still not satisfied with my virtual graphic adapter since the last line of the log says:

    "Error: OpenGL 2.0 not supported. Make sure you have the latest video card installed and hardware acceleration is turned on."

    I started OpenGL Extension Viewer and it gave me Version 1.1 only.
    So it seems I need to dig deeper how to enable the D3D support in Win81 for Virtual Box.

    Newbie

    41 Posts

  • #4, by afrlmeFriday, 09. October 2015, 15:49 5 years ago
    Is there no other VM you can use? & have you updated your GPU drivers recently? There's another user on here that is running VS on Linux through a VM. He posted a thread a couple days ago. Username is "NormalUser".

    http://www.visionaire-studio.net/forum/thread/linux-wine-con...

    He said he'd managed to get it running after messing around for a while without it crashing every 2 minutes. Maybe you could ask him what he did to sort it out?

    Imperator

    6842 Posts

  • #5, by LebosteinFriday, 09. October 2015, 16:08 5 years ago
    Yes! Same problem here (VirtualBox with Windows XP on a Linux machine). You can open Visionaire and open ONE of the editors (scene editor, character editor, interface editor...) and you can work. But if you switch to an other editor (or resize the current window) then Visionaire crashes in 100 % of the cases. All other things work. You can run the game without problems.

    I think the Visionaire editor uses some directx panels/overlays (checkered backgrounds) to display the graphics inside the editor. And it seems there is a problem while closing or resizing that panels. This could be a problem of VirtualBox (or a wrong implementation by Visionaire?), I don't know...

    PS: Before it crashes, I can see the graphic panel of the new editor with chaotic graphical remains in it. In my case I see fragments of game screens and other things I had played days before! Like a time machine....

    Key Killer

    601 Posts

  • #6, by NormalUserSaturday, 10. October 2015, 11:35 5 years ago
    I tried it with virtualbox at first as well but switched to WINE. Runs pretty good besides the occasional crash (roughly once an hour, so save often).

    Newbie

    24 Posts

  • #7, by htw8849Monday, 12. October 2015, 17:51 5 years ago
    Sorry for coming back so late on this subject, but it took my a while to enable the D3D-support in Virtualbox.
    In fact I had to switch back to Windows 7 in order to get in running.

    This time the visionaire editor started and I was also able to switch between the different editor interfaces (scene editor, character editor and so on...), but I ended up at the same situation that von Lebostein described: None of the grafix are display and if you switch editor panels 3 times or resize the window multiple time, the editor crashes with a coredump at the location AFRLme descripted.

    Interesting: During editor panel switchting or resizeing the grafix are flickering through - but in a very distorted way (looks like that the bg-buffer is completly messed up)

    If you want, I could sent the zip-file with the crashdump.

    Newbie

    41 Posts

Write post