Easing functions questions [SOLVED]

  • #1, by red363Monday, 11. July, 03:26 A month ago
    Hi!

    Can you please tell me if it is possible to disable the "easing function" if I want to enlarge a part of the scene, rotate an object, etc.?

    Where I just wrote "none":
    shaderViewport(50, 945-19, 265-11, 0, 7000, none)

    Thanks

    Newbie

    71 Posts


  • #2, by esmeraldaMonday, 11. July, 12:11 A month ago
    just leave it empty or use the linear easing (easeLinearIn)
    there is even easeNoneIn, that should wait for the time set as delay and then jump to the designated scale.
    (and of course these easing exist as ...Out and ...InOut like any other easing)

    Great Poster

    458 Posts

  • #3, by red363Monday, 11. July, 17:49 A month ago
    just leave it empty or use the linear easing (easeLinearIn)
    there is even easeNoneIn, that should wait for the time set as delay and then jump to the designated scale.
    (and of course these easing exist as ...Out and ...InOut like any other easing)
    Thanks for the answer.
    Maybe I don't fully understand something...

    If I leave it empty, nothing happens.
    If I use "easeNoneIn" the increase is instantaneous, without a smooth fade.
    If I use "easeLinearIn" - the increase occurs along a curve, but I just don't need it.

    I need to have the usual smooth increase over a given period of time to the desired size without deflecting the camera trajectory in the process.

    Newbie

    71 Posts

  • #4, by afrlmeMonday, 11. July, 20:22 A month ago
    easeLinearInOut is the default one, which should be a straight line from point A to point B without any curving. If you want the start to have the same curve as the end then you need to include InOut at the end of the easing type.

    Also what you are saying is not making a lot of sense to me, so I'm probably misunderstanding what it is you are trying to do.

    Imperator

    7158 Posts

  • #5, by red363Monday, 11. July, 21:19 A month ago
    Thanks everyone, I think I figured out what the problem was. Found the answer here:

    https://www.visionaire-studio.net/forum/thread/shaderviewpor...

    Newbie

    71 Posts

Write post