disable text skipping

  • #1, by gustySaturday, 07. December 2013, 19:36 7 years ago
    Hello, how can I achieve "non-skippable" text during the character dialogs? I set "Always allow to skip active text" in Game properties to off and I added "beggin cutscene" actionpart before "start dialog" and after that I added "end cutscene" of course. But I'm able to skip dialog text with left clicking anyway :/. Anybody knows how to disable skipping completely? I do not use "display text" actionpart at all, I only use "start dialog" for all the text in my game. Maybe some global script would help? Thanks for your thoughts.

    Forum Fan

    159 Posts


  • #2, by afrlmeSaturday, 07. December 2013, 20:27 7 years ago
    hmm...
    from the wiki:

    Start dialog/dialog-layer

    Starts dialog between the current character and a partner. The dialog has to be created under the dialog option of the addressed character. Following action parts will be executed immediately so take care if this is not the last action part of the listed actions.


    If you read the quote I just added from the wiki then it says that any action parts listed after the start dialog will be executed immediately rather than waiting until after the dialog has ended.

    So in other words the end cutscene action part you added is being voided pretty much straight away & I'm not sure it would work anyway? (I've not tested mind & if it does then... you should add the end cutscene action part to as an action to the dialog option that ends the dialog)

    Always allow skip text is for allowing player to skip text during cut-scenes & even if the mouse has been disabled.

    Imperator

    6846 Posts

  • #3, by gustySunday, 08. December 2013, 19:25 7 years ago
    It doesn't work. I added "end cutscene" actionpart to the dialog option that ends the dialog as you suggested and still I'm able to skip the text. I also tried to add "beggin cutscene" to the particular dialog parts and it doesn't work neither.

    But nevermind, I already built my own dialogbox via "miscellaneous interface" and I'm using "display text" actionparts instead of "start dialog" actions. It works beautifully and I can have graphical icons for questions instead of plain text labels, just like in Broken Sword smile

    Forum Fan

    159 Posts

  • #4, by gustySunday, 08. December 2013, 19:40 7 years ago
    Hmm, now left-clicking with mouse is covered, but Escape key still skips the cutscenes :-/. Even if you would set some "blank" actionpart on Escape key - during the cutscene at first it would skip the cutscene and then it would perform desired action. Seriously what is the deal with text-skipping in Visionaire? Man I just want something to disable, why is it so tricky?

    Forum Fan

    159 Posts

  • #5, by afrlmeSunday, 08. December 2013, 22:52 7 years ago
    if you hide the mouse cursor (found under miscellaneous) just before you add the begin cutscene action then it will prevent using escape key I think?

    hide cursor action disables all key input.
    you must remember to show the cursor after the cutscene has ended.

    Imperator

    6846 Posts

  • #6, by gustyMonday, 09. December 2013, 10:40 7 years ago
    if you hide the mouse cursor (found under miscellaneous) just before you add the begin cutscene action then it will prevent using escape key I think?


    No it won't. Actually, "Begin cutscene" is just combination of two existing actionparts: Hide cursor and Hide interface (inventory).

    Forum Fan

    159 Posts

  • #7, by afrlmeMonday, 09. December 2013, 13:06 7 years ago
    ah hmm try using hide cursor on its own then.

    Imperator

    6846 Posts

  • #8, by gustyMonday, 09. December 2013, 13:16 7 years ago
    ah hmm try using hide cursor on its own then.

    IT WORKS!!! Thanks man!! smile

    Forum Fan

    159 Posts

  • #9, by afrlmeMonday, 09. December 2013, 14:15 7 years ago
    yay! razz

    yeah I forgot that hide cursor in combination with begin cutscene doesn't disable all key input.

    Imperator

    6846 Posts

Write post