Crash on renaming object (bug?)

  • #1, by XerilonThursday, 19. May 2016, 18:20 4 years ago
    When I make a new scene and add an object, Visionaire crashes as soon as I click the object to rename it... This prevent me from starting my project..

    "An unhandled win32 exception occurred in viseditor.exe (15824)"

    Newbie

    37 Posts


  • #2, by afrlmeThursday, 19. May 2016, 21:04 4 years ago
    Is this the only thing causing it to crash? Or does it crash when you try to do other things as well?

    It might be an idea to check the log file. Also after it crashes does it give you the option to submit a report / create a dump file or anything like that? If it does then you can send the dmp file to one of the VS devs & they should be able to figure out the issue from that.

    I recommend providing some specs as well... computer / laptop make, model, ram, graphics card specs, os, cpu, etc.

    Imperator

    6842 Posts

  • #3, by XerilonFriday, 20. May 2016, 23:11 4 years ago
    Hello, and thanks for the reply, though I got it on mail, then replied and received a denial status today (lol my fault)!

    I got the same crash when clicking back and forth on the left menu buttons for a few seconds (scene, interface etc.) and got the new error: 11460
    I will send the dmp file..

    I use a regular computer with Windows 10 (64)
    Intel i7-3770K CPU @ 3.50GHz 3.50GHz
    16gb ram
    GPU GTX 970

    Visionaire has never caused any problems before the latest version.
    Thanks again for the support!

    EDIT: How do I send over the dmp file?

    Newbie

    37 Posts

  • #4, by afrlmeFriday, 20. May 2016, 23:59 4 years ago
    You can use dropbox or sendspace or some similar service & send it via pm (private message) to either David (BigStans) or SimonS - I recommend sending it to SimonS as he's currently the most active dev.

    P.S: it sounds like the same issue I've been having. For me it just started randomly the other week. I couldn't figure out what was causing it & it wouldn't let me create a dmp or send a report. I tried uninstalling & re-installing VS without joy too... also checked for virus. Ended up upgrading to windows 10 & updating my gpu / apu drivers to latest versions, which also didn't help. The only thing that helped me was overwriting the editor with another version, opening that & then replacing the editor back with the current version...

    however... the editor has other issues now on my windows machine related to openGL (I don't remember the exact reason / explanation that Simon gave me for the issue), but suffice it to say, all the preview sections of the editor randomly go black & the only way to make them display correctly again is to close & reopen the editor. My temporary solution while I wait for a team / dev build or the upcoming new IDE was to install windows 8.1 on Parallels VM on my mac. Sure I could have just used the mac version of the editor, but it's buggy & I don't like cross-polluting my project files, unless I can't avoid doing so.

    Imperator

    6842 Posts

  • #5, by XerilonSaturday, 21. May 2016, 00:14 4 years ago
    Lol, I'm glad I am not alone with that stuff then smile

    I have also tried reinstalling and virus checking too, and all drivers are up to date smile

    Oh, well, I have tons of prerendering graphics to do while waiting, and I am familiar using visionaire so I know what graphics to put out smile

    Newbie

    37 Posts

  • #6, by afrlmeSaturday, 21. May 2016, 01:05 4 years ago
    By the way, you can actually downgrade to the previous version of VS as there's a dropdown menu in the popup window where you input your name & license key. I think it goes all the way back to the 4.0 beta.

    Imperator

    6842 Posts

  • #7, by XerilonSaturday, 21. May 2016, 12:45 4 years ago
    Thanks for the tip on that! It may work smile

    Newbie

    37 Posts

  • #8, by XerilonSaturday, 21. May 2016, 13:06 4 years ago
    Does this log window say anything useful?

    Newbie

    37 Posts

  • #9, by afrlmeSaturday, 21. May 2016, 14:01 4 years ago
    Well it tells me you are using an older version of the editor. The warnings however will probably mean something to the devs - I don't have access to the source code of the engine myself. My support is more related to general issues & helping people as opposed to internal engine issues.

    P.S: the most recent build is 4.2.5 (1186). I think 4.2 was quite buggy in general. 4.2.5 seemed to be a bit more stable, but still contains various issues caused by wxWidgets.

    Imperator

    6842 Posts

  • #10, by XerilonSaturday, 21. May 2016, 16:05 4 years ago
    Aha, ok, I didn't know the newest version was that new :p

    I'll upgrade and try it!

    Newbie

    37 Posts

  • #11, by XerilonSaturday, 21. May 2016, 16:23 4 years ago
    Weird enough it crashes just the same. I made a new project with a new folder too. It seems stable as long as I don't click on anything, but that is rather useless :p

    I also installed the 4.0 version and that crashed too, so now I have three running versions with the same crash problem. I suspect my hardware, but I don't know...

    Newbie

    37 Posts

Write post