Character only moves up after loading savegame

  • #1, by shorty-mcsharkFriday, 17. July, 14:13 3 weeks ago
    Hi there,

    I hope someone can help me with a little (or big?) problem: after loading a savegame, I can't really move the character. If I click just somewhere inside the waysystem (or outside the wayborders), the "walk"-animation starts and doesn't stop - and the character doesn't move. If I tell the character to go "up" (everything between 45° and 135°) and inside the wayborders, he does what I expect him to do (walk up, stop there). 
    It only appears when I shut down the game and start it again, save and load within the same session seems to work...
    Seems like it's not depending on the complexity of the waysystem...
    Any ideas, anybody? I'm grateful for any hints.

    Best regards,
    Georg

    Hallo Leute,

    Ich hoffe jemand kann mir mit einem kleinen (oder großen) Problem helfen: nachdem ich einen Spielstand geladen habe, kann ich den Charakter nicht mehr wirklich bewegen. Wenn ich einfach irgendwo innerhalb des Wegsystems (oder außerhalb der Weggrenzen) klicke, startet die "walk"-Animation und hört nicht mehr auf - und der Charakter bewegt sich nicht. Wenn ich ihm sage, dass er "nach oben" (alles zwischen 45° und 135°) und innerhalb der Weggrenzen gehen soll, macht er das, was ich von ihm erwarte (nach oben gehen, dort stehen bleiben). Es passiert nur, wenn ich das das Spiel schließe und wieder starte, speichern und laden innerhalb derselben Session scheint zu funktionieren. Es scheint, als hinge es nicht von der Komplexität des Wegsystems ab...
    Irgendwelche Ideen, irgendjemand? Ich bin sehr dankbar für jeden Hinweis!

    Beste Grüße,
    Georg

    Newbie

    4 Posts


  • #2, by MachtnixFriday, 17. July, 15:12 3 weeks ago
    Ist der Startpunkt des Characters von Anfang an (bei Beginn des Spiels) innerhalb des Wegsystems und ist ihm ein Wegsystem zugewiesen worden? Somit kann er das Wegsystem nicht verlassen. 
    Gibt es zudem gar keine Wegpunkte, läuft die Figur tatsächlich etwas orientierungslos. Besser: mindestens ein Netz von zwei, drei Punkten setzen.
    Hat jedes Outfit der Figur (stehen, laufen, usw.) einen definierten Mittelpunkt? Das ist ein Koordinatenkreuz, das zumeist unter die Füße gesetzt werden muss. Ohne diesen Punkt könnte die Figur nirgends hinlaufen.

    Thread Captain

    1079 Posts

  • #3, by shorty-mcsharkFriday, 17. July, 15:22 3 weeks ago
    Jap, ist er. Wie kann ich denn einem Charakter ein Wegsystem zuordnen? Es ist in dem Raum als Standard ausgewählt. Es wird im späteren Verlauf auch mal gewechselt, aber nicht bis zum Test-Savegame. Es funktioniert ja auch alles, bis ich das Spiel beende und wieder lade. Sehr merkwürdig.
    Ich habe es schon ganz ohne Wegpunkte versucht, standardmäßig hat mein Wegsystem aber mehr Wegpunkte, vielleicht so 20.
    Alle Outfits sind mit "Kreuz", allerdings sind zwei gespiegelt. Die einzige, die weder gespiegelt ist noch wird, ist auch die, die funktioniert.Vielleicht hängt es damit zusammen?

    Newbie

    4 Posts

  • #4, by MachtnixFriday, 17. July, 15:37 3 weeks ago
    In den Spieleinstellungen gibt es die Option, die Start-Figur festzulegen, das Objekt, an dem sie steht, und auf welcher Kulisse, die Schrift, die sie benutzt und einiges anderes. Enweder steht das Wegsystem dort - oder bei den allgemeinen Einstellungen der Figur-Outfits. Aus dem Kopf weiß ich das gerade nicht.

    Gespiegelte Outfits sollten kein Problem sein. Wichtig ist natürlich, dass alle Laufrichtungen auch mit einer Pose im entsprechenden Winkel abgedeckt sind. Aber wäre das nicht so, verschwindet die Figur einfach.

    Thread Captain

    1079 Posts

  • #5, by shorty-mcsharkFriday, 17. July, 15:42 3 weeks ago
    Ich habe das Problem gelöst - es war wohl ziemlich sicher ein Bug. Die Back-Animation und die Right-Animation waren erstellt, Left und Front waren nur die gespiegelte Right-Animation. Up ging, alles was mit Right zusammenhing, also auch die gespiegelten, ging nicht. Habe die Right-Animation gelöscht und neu gemacht, jetzt gehts... Das erklär mir mal einer... ^^
    Danke für die Hilfe!

    Newbie

    4 Posts

  • #6, by MachtnixFriday, 17. July, 16:01 3 weeks ago
    Schon merkwürdig, dass der Fehler nicht inmitten des Spiels auftrat, sondern erst nach Neuladen. Der Editor legt übrigens eine Bak-Datei beim Speichern an - darauf lässt sich zur Not zurückgreifen. Vielleicht war einfach die Ved-Datei beschädigt. Es ist ohnehin empfehlenswert, sich nicht nur auf EINE Spieldatei zu verlassen...

    Vor jeder einschneidenden Änderung lege ich eine neue Datei an. Es kam oft vor, dass ich dann wieder auf Spiel Nr.5 zurückgreifen musste, obwohl ich schon bei Spiel Nr. 9 war...

    Thread Captain

    1079 Posts

  • #7, by shorty-mcsharkFriday, 17. July, 17:44 3 weeks ago
    Das ist ein guter Hinweis, danke! Sollte ich vielleicht tatsächlich mal machen...

    Newbie

    4 Posts

Write post