Character disappears when getting close to Way borders

  • #10, by JoelFriday, 30. October 2015, 19:35 5 years ago
    I will, thank you wink I just had to make some starting sense of it all or i wouldn't have understood ANYTHING but now i feel i can take a look at the other projects and get a bit a clearer picture smile

    Forum Fan

    129 Posts


  • #11, by afrlmeFriday, 30. October 2015, 21:38 5 years ago
    In regards to character animations... if you delete any of the character animations from walk, idle or talk then it will automatically default to one of the remaining animations. If an animation for a specific direction exists however & you've not added any animation sprites to it, then it will still try to draw said animation.

    As for the walking... if you don't want the character to slide then you have to disable sliding option thing in the characters outfit properties tab then you have to manually adjust each animation frame for each of the walk animation directions using the footstep (movement) tool.

    Quick tip: when sorting out the distances I recommend using the onion tool & then selecting the frame next to it. (see red dot). This will allow you to simply press & hold the increase / decrease buttons of the movement input box until the frames line up. With this method it's pretty easy & fast to sort out the movement. The most complicated movement directions to sort out are north & south.

    Imperator

    6846 Posts

  • #12, by JoelFriday, 30. October 2015, 21:40 5 years ago
    The sliding is fine, the problem is that the Character doesn't slide faster when i adjust the Walking Speed in the Outfit Properties. At least not from left to right i think it works up and down.

    Forum Fan

    129 Posts

  • #13, by afrlmeSaturday, 31. October 2015, 02:20 5 years ago
    hmm if you are using the sliding option in the character outfit properties tab then it should be influenced by the walk speed you set in the same tab.

    If not then go to walk animations of the outfit, click on the footstep icon & then click on the big red x icon (furthest right) on the toolbar. This will reinitialize the movement values based on the walk speed set in the outfit properties tab. Repeat this for each of your walk animations.

    Imperator

    6846 Posts

  • #14, by JoelSaturday, 31. October 2015, 10:19 5 years ago
    Gee Man, how can it be that every time you comment the obvious thing (which i could swear i've tried 100 times before), it suddenly works smile You must be a wizard or something.

    Of course, it was the footstep and red x icon (which i knew but as i said i was SURE i deleted it everywhere).

    *sigh* thanks so much for your support! red Next time i'll double and triple check before asking these questions BUT, i'm happy to report that i figured out how to build my inventory system all on my own grin


    Ooh i think i knew what my problem was. I didn't get that i have to re-initialize the Data by clicking on the red X again so i got a total mix-up. All clear now!

    Forum Fan

    129 Posts

  • #15, by afrlmeSaturday, 31. October 2015, 12:11 5 years ago
    No problem. Not a wizard (well not in real life anyway - I'll leave that up to Simon), I am however the go to person for Visionaire Studio support (except 3D model part of it as I'm not remotely savvy on 3D stuff at all) & Lua script support.

    Imperator

    6846 Posts

  • #16, by JoelSaturday, 31. October 2015, 12:31 5 years ago
    I am however the go to person for Visionaire Studio support


    You bet wink

    Forum Fan

    129 Posts

Write post