Anyone checked out the new Shader stuff yet?

  • #20, by afrlmeWednesday, 13. August 2014, 17:26 6 years ago
    hmm very strange... I'm not sure why it should work ok with 3000ms delay as opposed to 2000ms delay.

    One bit of advice I can offer though is in regards to the key input actions. You should use key (released) actions instead of the default key actions; scroll down the list to find the released section.

    The reason for this is because the default key presses act similar to rapid fire/turbo option on certain controllers, meaning that whatever actions are listed will repeatedly get executed over & over again until the key is released, whereas the released key will only execute the listed actions once you have released the key.

    Imperator

    6816 Posts


  • #21, by afrlmeWednesday, 13. August 2014, 18:15 6 years ago
    I tested out what you posted & got same results. Very strange indeed. Could be some bug/oversight in the script Simon wrote mind, or could be an internal issue. I'm not sure. By all accounts: as soon as stopfollow is executed it should deactivate the follow loop in the shaderMain() function.

    Imperator

    6816 Posts

  • #22, by afrlmeSaturday, 16. August 2014, 19:18 6 years ago
    I've made a temporary fix for the shaderFollowCharacter & shaderStopFollow functions.

    shaderStopFollow function now automatically resets viewport back to default with same amount of delay that you specified in the shaderFollowCharacter function.

    You can also specify the easing for shaderStopFollow like so:
    shaderStopFollow(easeQuintOut) -- stop following character, reset viewport with easeQuintOut easing...
    1
    2


    You will need to replace previous shader toolkit with the updated script.

    In regards to the issue: I tried multiple different methods & could not get it to stop snapping back to zoom value set in the shaderFollowCharacter function, when delay was less than shader_follow.delay. Camera worked normally again after the snap back when I tried viewport function afterwards.

    Imperator

    6816 Posts

  • #23, by unrealMonday, 18. August 2014, 19:39 6 years ago
    I've followed the instructions for the scripts examples but "Execute a script" doesn't work elsewhere than using pressed keys (like "A", "T" or whatever the key). I've searched in the logs for the some errors but nothing. I don't get it, am I missing something ?

    P.S. : The effects are really cool by the way ! wink

    Newbie

    66 Posts

  • #24, by afrlmeMonday, 18. August 2014, 19:50 6 years ago
    execute a script will, execute any code inside of the code block.

    You need to make sure you have the shader Toolkit script added as a definition script for the shader functions to work.

    The Toolkit script provides the initial setup & defines the functions & creates a loop that is used to check for when functions have been executed or custom shader scripts (glsl) have been executed in a function or script.

    Instead of setting up execute a script actions inside of key inputs or actions try using the console instead. Just hit the TAB key to open the console.

    then in console type: exec
    & then after exec you type your script & press enter.

    quick example:
    exec shaderContrast(1.1, 3000)
    1
    2

    Imperator

    6816 Posts

Write post