Warum spricht sie nicht??

  • #1, by MuklinWednesday, 14. December 2016, 06:31 4 years ago
    Also ganz knapp: Ich habe einen Dialog über mehrere Kulissen (Quasi als Behelf für eine Art Diashow im Hintergrund) laufen, und wenn ich die Kulisse wechsel und ein Charakter "zu Beginn der Kulisse" Etwas sagen soll, gibt's entweder den Fall, dass er Stumm bleibt, oder dass sein Text nur einen kurzen Moment abgespielt wird; anstelle von "Hallo Welt" bleibt dann nur Zeit für "H".

    Ich habe versucht, das Problem mithilfe einer Zwischensequenz und einer Pause zu lösen, aber mein Charakter bleibt stur. Auch habe ich "Warte, bis Person zu Ende gesprochen hat" probiert; allerdings ebenfalls ohne Erfolg.

    Ich gehe davon aus, dass mir hier irgendein grundlegendes Verständnis für irgendwas fehlt; aber wenn ich wüsste, was ich da genau verpasst habe, was ich hier brauche, dann würde ich hier jetzt nicht tippen. Es erinnert mich sehr stark an ein fieses Problem, was ich mit der Sensorprogrammierung einer Füllstandsanzeige hatte; alle anderen machen's genauso aber bei mir klappts natürlich so nicht. "Eigentlich habt Ihr alles genauso gemacht, wie es sein soll. Also ist es quasi richtig; es funktioniert nur nicht..." Wir haben's dann anders doch geschafft smile

    Genug abgeschweift. Ich bin mir nicht einmal mehr ganz so sicher, ob dieser Dialog so stattfinden wird, aber ich würde gerne meinen Fehler verstehen. So wie es aussieht, arbeite ich inzwischen allein an diesem Projekt und wenn ich jedes Problemchen einfach stillschweigend hinnehme oder mir den Kopf zermartere, anstall jemanden doch um Rat zu fragen, wird Onmind-Saga nicht das, was es werden könnte. roll

    Und Nochmal um es klar zu stellen: Nur der erste Text wird nicht angezeigt; und wenn, dann wird der Ton nicht abgespielt.

    Newbie

    94 Posts


  • #2, by sebastianWednesday, 14. December 2016, 08:23 4 years ago
    es geht also um den Text von "Erde_Kornelia"? Kannst du zu diesem Text nochmal einen Screenshot machen? 
    Mögliche Ursachen könnten enthaltene Pausen, eine zu kurze verknüpfte Audiodatei oder gar etwas im Zusammenhang mit dem fade-in beim Kulissenwechsel zu tun haben... 
    Ist dies schon die Kulisse, auf die gewechselt wurde? Falls ja: Wie schaut die Aktion von der vorherigen Kulisse aus? ggf. wird hier noch irgendwie Einfluss genommen... 

    Grüße 
    Sebastian 

    Thread Captain

    2337 Posts

  • #3, by MuklinWednesday, 14. December 2016, 09:30 4 years ago
    Also der Text von Erde_Kornelia:
    Also Abigail<;p2>;jetzt erzähl mir doch<;p2>;endlich etwas über Deine Heimat.<;p3>;
    1

    Also könnte das Problem an der Audiodatei liegen? Ich sollte also darauf achten, dass die Audiodatei lieber etwas zu lang als zu kurz ist. Was habe ich denn zu befürchten, wenn meine Audiodateien das "wav" Format haben und keines der empfohlenen Formate? Naja, außer dass mein Audioordner mächtig wird grin 

    Vor dieser Kulisse wurde auf "Neues Spiel" geklickt. Und da wird Autosave #0 geladen und dann Autosave #0 gespeichert. Nach dieser Kulisse habe ich allerdings dasselbe Problem.

    Übrigens wird an dieser Stelle MAIN_Abigal nicht gespielt; weil MAIN_Abigal Dinge weiß, die der Spieler nicht weiß, und es nur Sinn macht, dass Erde_Kornelia blöde Fragen stellt. (Dieser Fakt bereitet mir schon seit einem Jahr Kopfzerbrechen; eigentlich ist das ganze erste Spiel nur Vorgeschichte grin Tja so ist das, wenn die Story eines Point'n'Clicks zu mächtig ist...)

    Tja und danach kommt erzählt MAIN_Abigal eine Legende, die gleichzeitig ein Tutorial ist, was auf dem Tisch der beiden Klatschtanten passiert. Demnach müssen die Charaktere auf dem Tisch immer mal wieder eine "Choreographie" hinlegen (Schicke Charakter zu Position xy/Lass Charakter verschwinden...) und meine Charaktere machen alles, absolut alles, aber nicht das, was sie sollten. Das macht mich total wahnsinnig.
    Ich mache vielleicht nicht alles richtig, aber ich weiß, dass Programmieren/Scripten nicht so abläuft wie Kuchen backen. Warum sieht dann mein Resultat derart aus? roll 
    Kommt schon; kann doch nicht sein, dass ich an den simpelsten Programmieraufgaben scheitere.

    Kann man an den Grundlegenden Mechanismen von Visionaire schon SO viel falsch machen? Wie macht Ihr das denn mit den Ausgaben der Texte? Wenn ich einen Textteil wegklicke, wird die Audiodatei trotzdem ganz ruhig abgespielt. Drei <p>'s zu setzen scheint mir sinnvoller als drei mal "Gebe Text aus von Erde_Kornelia" zu verlangen.
    Es fehlt echt ein vernünftiges Handbuch zu Visionaire. Mein Programmierer hat mir seine Dienste verweigert, weil er lieber alles von Hand schreiben würde, weil das Tool bei uns so rumzickt. (da hab ich ihm aber nen Vogel gezeigt; zu dritt, neben dem Job, werden wir ja in 30 Jahren noch nicht fertig)

    Newbie

    94 Posts

  • #4, by sebastianWednesday, 14. December 2016, 11:50 4 years ago
    es könnte sein, dass deine p2,  p3 tags der Auslöser für das Verhalten sind. 
    Probiere mal anstatt p2 "p2000ms"  

    Thread Captain

    2337 Posts

  • #5, by MachtnixWednesday, 14. December 2016, 17:15 4 years ago
    Als blauäugiger Laie würde ich jetzt vorschlagen, den Start des Dialogs davon abhängig zu machen, ob die Kulisse geladen wurde oder nicht. Also etwas in der Art: "wenn Kulisse B geladen, setze Wert = 1. Erst wenn Wert = 1, starte Dialog." Ich kann mir nämlich vorstellen, dass das Rumeiern mit Millisekunden immer nur ein Kompromiss ist, weil intern Aktionen und Scripte ineinander verflochten sind und immer andere Resultate dabei herauskommen. Ich habe solche Probleme monatelang auch mit Pausen lösen wollen - aber es hat nie 100% geklappt.

    Thread Captain

    1087 Posts

Write post