Vorlaufzeit beim Partikelsystem generiert unerwartetes Ergebnis

  • #1, by LebosteinWednesday, 18. January 2017, 09:08 3 years ago
    Ich habe mit dem Partikelsystem jetzt schönen Schnee hinbekommen. Er rieselt über die gesamte Bildschirmbreite von oben herab (große, schnellere Flocken vorn und langsame kleine hinten, etwas chaotisch, sieht wirklich echt aus). Damit es beim Raumwechsel nicht jedesmal neu zu schneien beginnt, wollte ich 10 Sekunden vorspulen, damit die gesamte Bildfläche schon mit Partikeln gefüllt ist. Nun tritt aber der Effekt ein, dass während des Vorspulens nicht die gesamte Breite beschneit wird, sondern alle Flocken aus der Koordinate 0,0 zu sprießen scheinen. Wenn man den Raum betritt, ist der gesamte linke Rand voller Flocken und erst ab diesem Zeitpunkt beginnt es wie gewollt über die gesamte Breite zu schneien.

    PS: Kann man irgendwo nachlesen, was die ganzen Einstellungen bedeuten/bewirken? Das wenige, was ich brauchte, habe ich völlig blind mit dem trial and error Prinzip versucht, rauszufinden...

    Key Killer

    598 Posts


  • #2, by LebosteinWednesday, 18. January 2017, 12:17 3 years ago
    Problem 2: Wenn man es mit den großen und schnellen Vordergrund-Schneeflocken etwas übertreibt (was trotzdem gut aussieht), wird die unsymmetrische Skalierung der Partikel deutlich. Ich nutze ein 1 X 1 großes weißes Pixel als Schneeflocke. Dieses scheint aber nicht gleichmäßig hochskaliert zu werden. Unten links ist der Übergang hart, oben rechts weich. Wie kann man das verhindern?

    Key Killer

    598 Posts

Write post