Visionaire 5.0.8 with older macs

  • #1, by davide-berardiSunday, 16. December 2018, 20:16 3 months ago
    Hey guys,

    I recently upgraded to 5.0.8 and the editor does not work. I get a red screen and the editor won't start. After researching a bit it seems that my 2011 MacBookPro does not support the latest version of Metal and that might be the reason. 
    Is that so? Is there a way to run the software in a different mode or something?
    Please help!

    Davide

    Newbie

    8 Posts


  • #2, by sebastianSunday, 16. December 2018, 23:43 3 months ago
    what macOS Version do you have?
    I asked Simon to implement an OS check for the next update to force opengl for pre Mojave macOS. 

    Thread Captain

    2277 Posts

  • #3, by davide-berardiMonday, 17. December 2018, 02:07 3 months ago
    High Sierra, and I can't update to Mojave, it tells me that my machine can't do it when I try.
    When is the next update coming? I'm working on a game and I can't downgrade to 5.0.6 which was working fine.

    Newbie

    8 Posts

  • #4, by SimonSMonday, 17. December 2018, 15:13 3 months ago
    I'll probably do an update this week, especially for the Mac users, there are problems with retina. I used the Mac version as indicator if metal is available, seemingly this does not work. Even though the engine only uses basic features. Maybe I'll just check for Mojave.

    Thread Captain

    1184 Posts

  • #5, by davide-berardiMonday, 17. December 2018, 18:23 3 months ago
    Ok great. Our production is halted because of this so looking forward to downloading the update!

    Newbie

    8 Posts

  • #6, by sebastianSunday, 30. December 2018, 22:57 2 months ago
    I'll probably do an update this week, especially for the Mac users, there are problems with retina. I used the Mac version as indicator if metal is available, seemingly this does not work. Even though the engine only uses basic features. Maybe I'll just check for Mojave.

    Any progress here?

    Thread Captain

    2277 Posts

  • #7, by sebastianTuesday, 01. January, 17:50 2 months ago
    It seems that not only the editor, but (of course) also the Player uses this implementation.
    So if i want to play a game build with the latest VS5 engine, i cant open it on older Mac versions where Metal is not available.
    Pretty frustrating for people who are stuck and cant update to Mojave.

    Thread Captain

    2277 Posts

Write post