V4.2.5 - Game keeps hanging or fast exiting

  • #1, by andiliddellSaturday, 12. March 2016, 23:32 5 years ago
    Howdy,

    It's been a looooong time since I've last used VS, but I heard there was a new version that had fixed the TTfont issues, so I thought it might be a chance for me to finally finish act 1 of my game.

    I've just downloaded my license copy of VS4.2.5 and loaded my only 4.2 dev file, and it keeps on crashing when I try to play the game through the editor.

    It either gets to the 2nd line of text dialog and hangs, or if I opne my coin interface and mouse over an icon it fast exits.

    It's been that long I cant even remember where the dump/log files get saved to share them with you, in the hope someone can diagnose what's wrong.

    Has anyone else been having crashes and fast exits?
    Can anyone help or point me to the log file?
    Are these my feet?

    Cheers,
    Andi.

    Forum Fan

    178 Posts


  • #2, by andiliddellSunday, 13. March 2016, 00:13 5 years ago
    Another self answering post... I did some hunting and wracking of the old brain and found the log file:

    c:/users/"yourname"/appdata/local/"companyname"/"gamename"

    Turns out an mp3 file which was used for the verb coin mouse over effect wasn't decoding properly and crashing the player. Weird as it played back in Media player and VLC player fine, but now VS doesn't like it for some reason?

    I've solved the other crashing problem by reverting back to bitmap fonts, but that's annoying as I came back to VS as I'd heard the TTfont issues were fixed?

    Any news on why they might be causing the player to hang?

    cheers

    Forum Fan

    178 Posts

  • #3, by afrlmeSunday, 13. March 2016, 00:19 5 years ago
    Yeah VS doesn't like mp3 files so much. Just convert your mp3 files into ogg (vobis) or opus format. Either is fine.

    Really I've not had any issues with using TTF / OTF fonts. Are they custom made or ones you have downloaded? Have you tried using any others to see if they also cause issues?

    Imperator

    6845 Posts

  • #4, by andiliddellSunday, 13. March 2016, 00:57 5 years ago
    The Adobe caslon font I was using displayed with each letter slightly off vertically, making them all look a bit drunk and jumbled.

    I've changed to Franklin demi cond font to check if its just that one, and now I'm getting a crash again. Log file says this:

    23:52:20: Engine Version: 4.2.5 (Build 1185 from Build date: Nov 24 2015)
    23:52:20: Time needed for preloading game: 12 msec
    23:52:20: Initializing graphics interface. Surface size: 1024x768, render size: 1024x768
    23:52:20: Using Framebuffer with texture.
    23:52:20: red, green, blue, alpha, depth size: <0, 0, 0, 0, 0>, doublebuffer <0>, accelerated <1>
    23:52:20: Serialization finished. Needed time: 27 ms
    23:52:20: SetupParents finished. Needed time: 1 ms
    23:52:20: SortLinks finished. Needed time: 0 ms
    23:52:20: Interfaces loaded. Needed time: 2 ms
    23:52:20: CharacterAction: start game script run!
    23:52:20: Scripts loaded. Needed time: 1 ms
    23:52:20: Time needed for loading game: 174 msec
    23:52:22: Warning: Illegal polygon border for object '01_Beach_night: area_distant island' (id: 21)
    23:52:28: log: 0(13) : warning C7563: assignment to uniform color
    0(13) : warning C7563: assignment to uniform color
    23:52:28: log: Fragment info
    -------------
    0(13) : warning C7563: assignment to uniform color
    0(13) : warning C7563: assignment to uniform color
    0(13) : warning C7563: assignment to uniform color
    0(13) : warning C7563: assignment to uniform color
    0(13) : warning C7563: assignment to uniform color
    23:52:36: Error: can't open file '' (error 0: the operation completed successfully.)
    23:52:36: Error: Could not open file ''
    23:52:36: Error: Accessing buffer of memory file but buffer does not exist


    No idea what is going wrong now? what's that assignment to uniform colour business?

    Forum Fan

    178 Posts

  • #5, by andiliddellSunday, 13. March 2016, 01:22 5 years ago
    I've changed fonts again and its stopped crashing? seems it really doesn't like some fonts. They're all pretty standard windows ones too that it's spitting out.

    The MP3/ogg issue is a real pain. When I made Fantasy Quest I think I decided to use .ogg from the outset, after you recommended it.

    I started this game 3 years ago and its 10 times the size of fantasy quest with ALOT of mp3 files in use. It seems to be crashing with random ones, no logic or pattern or reason why certain mp3's cause it to crash.

    It's easy enough for me to batch process all of the mp3's in audition to convert them to .ogg, but linking them all back up in VS is going to be a nightmare!

    Any ideas of how I could quickly link them all back up?

    EDIT: Mp3's don't crash the player in 4.2, this is a new bug to 4.2.5.

    MC visual studio debugger lists a problem in:
    Unhandled exception at 0x5747D390 (avcodec-56.dll) in viseditor.exe: 0xC0000005: Access violation reading location 0xCDDE48D7


    Forum Fan

    178 Posts

  • #6, by afrlmeSunday, 13. March 2016, 01:35 5 years ago
    Yeah I think Simon planned on removing the extension under the recommended audio formats in the popup open file windows.

    You can quickly change all instances of mp3 to ogg by opening up your ved file in a text editor like sublime text, notepad++ or atom. Search for all instances of mp3 & then click replace all & replace them with ogg. I would recommend creating a back-up of your ved file before editing it inside of a text editor as it's very easy to accidentally mess things up.

    Imperator

    6845 Posts

  • #7, by andiliddellSunday, 13. March 2016, 01:37 5 years ago
    that sounds like an excellent solution!

    Cheers Lee, I come back after a year off and your still coming up with the goods!

    Thanks mate, hope you're keeping well.

    Forum Fan

    178 Posts

Write post