Using the "Set Value" for audio containers?

  • #1, by nikolaj-de-haanWednesday, 02. September, 17:54 3 months ago
    Hi,

    I'm trying to control the volume of an audio container with the "Set Value" action, but is is not working for me. If test the value by previewing the sound in the audio system, it works when I write 100 in value box, but when I try setting it by an action in the scene it does not work. Can you see if I've done anything wrong in the two attached screenshots?

    (Sorry about al my audio related posts)

    Newbie

    20 Posts


  • #2, by afrlmeWednesday, 02. September, 21:06 3 months ago
    It's in dB not percent. You need to make sure that you set the type for the automation to dB. Then use values between 0 & -100, or whatever the lowest value is on those sliders.

    Quick note: 0 in dB, according to Simon's sound system is the actual recorded/exported volume level of the sound file.

    Imperator

    6862 Posts

  • #3, by nikolaj-de-haanThursday, 03. September, 22:49 3 months ago
    Thank you. However, it still does not seem to affect the volume of the sound. I have set it up like this. Is anything wrong?

    I want to set the value to -12 so the sound becomes 12 dB quieter...

    Newbie

    20 Posts

  • #4, by nikolaj-de-haanThursday, 03. September, 23:13 3 months ago
    Update: it works when I set the value to "-1200" in the audio container for testing.

    But when I try setting it in the scene with the action "Set Value", it does not work. Am I doing something wrong here?

    Thank you again!

    Newbie

    20 Posts

  • #5, by afrlmeFriday, 04. September, 00:39 3 months ago
    You have linked the value inside of the set value action part twice. razz

    Simon should really rename that second value to something else, as that second value lets you set the first value to the second linked value - just use the number part at the bottom instead.

    Imperator

    6862 Posts

  • #6, by nikolaj-de-haanFriday, 04. September, 01:05 3 months ago
    Oh - yeah I didn't get that field.

    So do you mean like this for setting it to "-2000". It still does not affect the volume of the sound

    Newbie

    20 Posts

  • #7, by afrlmeFriday, 04. September, 12:36 3 months ago
    I think you are missing something if it's not working. What about the min value? You have specified -90, but you are trying to subtract 2000 from the current value of the value.

    Quick note: the value operators are actual math types. Setting the operator to - & then setting the number to 2000 doesn't return -2000, it subtracts 2000 from the current number stored in the value & updates it to the new number. If you want to actually set -2000 then use = & change the number to -2000.

    Imperator

    6862 Posts

  • #8, by nikolaj-de-haanSunday, 13. September, 21:14 2 months ago
    Thank you. I tried doing what you suggested, so now I set the value with the “=“ operator to “-9000”. But is still does not do anything to the level of the track. I also tried with “-90” but that didn’t work either.

    Can you see anythting wrong in the screenshots here? Thank you!

    Newbie

    20 Posts

  • #9, by SimonSMonday, 14. September, 18:11 2 months ago
    An oversight on my part. It's fixed in the next version.

    Thread Captain

    1383 Posts

Write post