Suddenly no more sounds - FIXED

  • #1, by ZeroZeroQuatreMonday, 28. April 2014, 19:10 6 years ago
    Hi,

    I was about to finish a demo of my project when I realized that all my sounds weren't playing anymore.
    Music files are still working fine, but the various sounds scattered through the game are desperately silent now.
    My first thought was that I messed up somewhere, so I loaded one of my previous files (as I incremente my save every day) to give it a try.
    I picked one that worked flawlessy yesterday... and... same issue, silent sounds. No more pick-up-item sounds, no more cow sound, no more walking sound.
    I loaded another, older save, same issue.
    I had to go up to a file that was 3 weeks old for my sounds to finally play again.

    I'm struggling to understand what happened and what's still happening...
    • I use both .ogg and .mp3 (but so did I yesterday, and it worked yesterday D8)
    • I'm using Visionaire 4.0 beta (same as yesterday)
    • The preview buttin within Visionaire works, and the sounds are played. But once the game launched, silence.
    • I tried to build the game, but it didn't fix the issue.
    • I restared Visionaire multiple times, rebooted the computer, emptied the temp folders.

    I am pretty sure that I didn't alter ALL the sound files, nor move any folder (which is confirmed by the fact that my 3 weeks old save still works)

    Could it be a memory issue ?
    But why did it happen today ? And how could it retro-actively affect saves that days old ?

    Any advice or suggestion is more than welcome ! grin
    Thanks ^^

    Newbie

    10 Posts


  • #2, by afrlmeMonday, 28. April 2014, 19:54 6 years ago
    is there anything printed in either of the log files? & ideally you should be using .ogg (vorbis) format, not .mp3.

    & are you playing these via editor action parts or via Lua script?

    Imperator

    6842 Posts

  • #3, by ZeroZeroQuatreMonday, 28. April 2014, 20:21 6 years ago
    I checked the Help > Log-window, but didn't find anything that looked like an error.


    20:17:02:
    20:17:02: Log file for Visionaire Editor 4.0 Beta, full version (Build: 1164)
    20:17:02: Current date: 28.04.14 20:17
    20:17:02: -------------------------------------
    20:17:02: Loading 'D:\Program Files (x86)\Visionaire Studio 4\xml\structures.xml'...
    20:17:02: Loading 'D:\Program Files (x86)\Visionaire Studio 4\xml\actions.xml'...
    20:17:02: Loading 'D:\Program Files (x86)\Visionaire Studio 4\xml\actionParts.xml'...
    20:17:02: Finished sorting action parts.
    20:17:02: Loading valid links...
    20:17:02: Successfully loaded 'xml/validlinks.xml'.
    20:17:05: Serialization finished. Needed time: 26 ms
    20:17:05: SetupParents finished. Needed time: 1 ms
    20:17:05: SortLinks finished. Needed time: 2 ms


    And yes, I only work with action parts.

    I also tried something else :

    • I made a shortcut on "F10 > Play sound 'filename.ogg'", to see if I could play the sound that way.
    > It didn't work.

    • After that, I relaunched that 3 weeks old save, did the same trick : "F10 > Play sound blablabla"...
    > And it worked.

    Weird cry

    Newbie

    10 Posts

  • #4, by afrlmeMonday, 28. April 2014, 20:55 6 years ago
    Must be something you added/did since then. It is possible for certain things to corrupt every so often... scene objects, polygons etc. There are 2 log files. Also inside of the editor options you need to set log level to "info" for it to print everything.

    Imperator

    6842 Posts

  • #5, by AlexMonday, 28. April 2014, 21:38 6 years ago
    could it be that you disabled the sound or global volume?
    make sure that sounds are not disabled when starting the game from the editor (extras -> options -> player)

    check the log file after you pressed your F10 shortcut to play the sound for any error messages (press Tab in player, "print log" and scroll down)

    Great Poster

    378 Posts

  • #6, by ZeroZeroQuatreMonday, 28. April 2014, 22:05 6 years ago
    AFRLme > I set the log level to "info", but it didn't change much more alas cry
    I tried to open the .ved file and to look at the iterances of my .ogg filename, but even there, I didn't see anything unusual...

    Alex > I checked the sound and global volumes, but they weren't disabled confuse
    I tried the other tips, and...

    Newbie

    10 Posts

  • #7, by ZeroZeroQuatreMonday, 28. April 2014, 22:37 6 years ago
    ...
    TAB > PRINT LOG
    Doesn't even recognize me hitting F10, I can do it after, before, whilst Tab is open, nothing seems to work at all.
    And when I try to walk to my in-game cow for example, she plays the "Moo" animation, but no "Moo" sound. And the log doesn't recognize it neither.

    Also, when I go to
    TAB > PRINT SOUNDS
    It's kinda the same : nothing is even loaded, nor when I hit F10, neither when I talk to my in-game moo cow grin

    I tried to disable all the sounds from a scene (even the music), same issue : the logs stay empty.
    Funny fact though: I replaced the background music (an .ogg song) with my moo.ogg, and this time it worked.
    ?Moo Moo Moo Moo Moo Moo Moo Moo Moo Moo Moo Moo?

    For some reason, all my most recent .ved file read Background music, but nothing else anymore grin

    Can I get the "most annoying problem of the day" award ? XD

    Newbie

    10 Posts

  • #8, by ZeroZeroQuatreTuesday, 29. April 2014, 09:42 6 years ago
    Final edit :

    I found the issue, here's the description of what I did and how I fixed it, should someone have a similar issue one day.

    • I made a copy of my most recent file, gave it a try : no sound of course.
    • I started to trim my project file down, removing things step by step, and checking regulary if something would work. I started to remove all the characters but the main one, I then removed all the different scenes and locations, I removed all the actions, conditions, sounds but my F10 one.
    Finally, I ended leaving only the blank title screen with an EXIT button. Everything else was gone, no more Start actions, no more particules, no more interfaces but the mouse.
    I hit F10.
    Nothing.
    • I then went to my Game Properties and gave it another look again. I tried some of the options here, changed the action text, etc, etc...
    Still nothing.
    • Finally... I erased two elements : Company name and Game name.
    F10 : and here was my sound ! shock

    Ok.

    I went back to the Game Properties, wrote down the exact same information again... and... the sound was gone again.
    I erased the information : sound was back.

    I noticed that, when I left the mouse cursor over the Company & Game Name parts, Visionaire displayed briefly a huge block of help text (which sadly goes away way too fast everytime, so it's a bit annoying to read it XD)
    And here I read that Company Name and Game Name were used to save some important data of the game in the Local %appdata% folder.
    So I went there... and... indeed.
    I found a "config.ini" file, opened it, and two of those volumes were set to 0.
    So I erased my Company & Game Name folders from my %appdata% folder, launched the game anew, tried if the sound was still working, which it was, I then went back to check the "config.ini", and this time the sound wasn't set to 0 anymore.
    (but I'm still a bit confused, cause I still have GlobalVolume = 0 in there, but sounds works well, is that normal ?)

    I tried to understand what happened.
    And yesterday, during my final steps to finish my demo, I toyed around with an Action to control the audio volume : "Change Volume".
    But as I didn't get it to work, I removed it again from my project file.
    But it seems that this single test I did modified the whole "config.ini" and didn't switch it back once I removed the Action again.

    And this also explains why my 3 weeks old .ved file still worked : cause I didn't write Game & Company Names down at that moment, thus, it used the default folder, which wasn't modified by my aborted audio test I did yesterday.

    Voilà !
    Long explanation, sorry for the annoyance razz
    Thanks again for your help ! ^^
    (But no worries, I still have 1 or 2 questions left, so I'll surely annoy you some more in a different thread twist )

    Newbie

    10 Posts

  • #9, by afrlmeTuesday, 29. April 2014, 13:15 6 years ago
    If a config.ini exists then it automatically gets & saves the current volume levels. Anything else you see inside of a config.ini (check one of Daedalic games) has to be manually retrieved/saved via Lua script.

    If global volume is set to 0 then all sounds should be muted. This only applies if the config.ini is in the correct folder. If no company/game name is set then the config.ini should be placed into the project root folder where the .ved file is located.

    You really shouldn't include game/company name while developing your game anyway as it's a major pain having to click through appdata to access the log files, dump files & config.ini - when you need them.

    Imperator

    6842 Posts

Write post