Skipping text during cutscenes

  • #1, by brut69Monday, 11. July 2016, 11:55 4 years ago
    I am having a problem guys and I could really use some help
    I am starting a cutscene where a character gives another character a tour. During the first room that they meet where the cutscene starts , the user can't skip the text by left clicking (as it should). Once the characters however change scenes (still into cutscene mode), clicking a mouse button will cause them to skip the dialog that they are having (and I dont want that as it is time specific).
    I tried setting up each change of scene as a new cutscene (ending it at change scene and starting a new one) but that creates problems.
    Any ideas why is it doing that?
    Any way to disable mouse clicking ?

    Great Poster

    263 Posts


  • #2, by afrlmeMonday, 11. July 2016, 13:00 4 years ago
    You should be able to toggle text skipping on & off with...
    game.AlwaysAllowSkipText = true|false
    1


    P.S: maybe try using the hide / show mouse cursor action parts instead of the begin / end cutscene action parts. It's the same as the cutscene actions except you won't be able to skip the cutscene with the ESC key. Also no "a cutscene was started but incorrectly ended..." (something along those lines) error will be generated if you don't end the cutscene in the same scene.

    Imperator

    6842 Posts

  • #3, by brut69Monday, 11. July 2016, 16:09 4 years ago
    Thank you , I will try it and let you know

    Great Poster

    263 Posts

  • #4, by brut69Monday, 11. July 2016, 17:23 4 years ago
    This doesn't work...
    I set "Execute Script" then I put the code inside as true and it still lets me skip text

    Great Poster

    263 Posts

  • #5, by afrlmeMonday, 11. July 2016, 17:59 4 years ago
    true = skip, false = don't skip.

    Imperator

    6842 Posts

  • #6, by brut69Tuesday, 12. July 2016, 07:55 4 years ago
    That was my 2nd try once it wasn't working but it is still not working... cry

    Great Poster

    263 Posts

  • #7, by brut69Tuesday, 12. July 2016, 07:58 4 years ago
    I get this error


    [string "Start: Start Part: Execute script 'game.Alway..."]:2: attempt to index global 'game' (a userdata value)
    8:57:06 AM: stack traceback:
    [string "Start: Start Part: Execute script 'game.Alway..."]:6: in function '__newindex'
    [string "Start: Start Part: Execute script 'game.Alway..."]:2: in function <[string "Start: Start Part: Execute script 'game.Alway..."]:1>
    [C]: in function 'xpcall'
    [string "Start: Start Part: Execute script 'game.Alway..."]:1: in main chunk
    1
    2
    3
    4
    5
    6
    7
    8
    9

    Great Poster

    263 Posts

  • #8, by afrlmeTuesday, 12. July 2016, 12:54 4 years ago
    I just tried in 4.2.5 & it's working fine for me.
    game.AlwaysAllowSkipText = false
    1
    2

    Where are you executing the execute a script action part?

    By the way, you can determine if text is skippable or not (for cutscenes / hide cursor events) on the main game (cog) tab via the "Always allow to skip text" checkbox.

    Imperator

    6842 Posts

  • #9, by brut69Tuesday, 12. July 2016, 13:32 4 years ago
    "Always allow to skip text" is not ticked in the main menu
    Here is a screen shot of where it works and where it bugs out, thank you for all your help grin , I am really close to releasing the demo and this is one of the main "bugs"

    Great Poster

    263 Posts

  • #10, by brut69Tuesday, 12. July 2016, 13:33 4 years ago
    I tried switching to another hero , still the same

    Great Poster

    263 Posts

  • #11, by ElobranieTuesday, 12. July 2016, 14:13 4 years ago
    wink wink wink

    Newbie

    1 Posts

Write post