ShaderExclude kills Scene-Fade

  • #1, by caligarimarteWednesday, 18. May 2016, 20:13 4 years ago
    The regular Fade-to-Black on a Scene-Change works fine, but then when the new Scene should fade in, the Screen stays black until the Fade (which cannot be seen, all I see is Black) is over, then the Screen appears in an Instant.
    This only happens when GameShaderExclude is set to 1 or above in my StartUp-Script.
    The really strange Thing is that the Fade-Out works, but the Fade-In does not, but that makes me guess that the Bug should be easy to fix, as whatever makes the Fade-Out work only needs to be applied to the Fade-In, I suppose.

    Forum Fan

    145 Posts


  • #2, by afrlmeWednesday, 18. May 2016, 22:52 4 years ago
    I know the scene transition effects are a bit buggy in general. You could try disabling the ShaderExclude before changing scenes & re-enable it after loading a new scene. Write a small function or just include the ShaderExclude line of code inside of execute a script actions.

    Imperator

    6812 Posts

Write post