Running a game in window mode is broken

  • #1, by fulviovMonday, 30. April 2018, 12:41 2 years ago

    Running a game in window mode seems to be broken with the latest build.

    This is how my .ini looks like:

    FILE = MyGame
    #
    # FULLSCREEN = {yes|no}
    # yes - starts the game in fullscreen
    # no - starts the game in a window
    FULLSCREEN = no
    #
    # RESOLUTION = {Auto|Desktop|Game}
    # Auto - wide-screen support is activated if a wide-screen display is detected
    # Desktop - current desktop resolution is used when game is started in full screen mode
    # Game - game is initialized with the resolution specified in the game
    RESOLUTION = desktop
    #
    # INTRO = {yes|no}
    # yes - Show the intro movie on start-up
    # no - Don't show the intro movie
    #
    # LANGUAGE = {German|English|...}
    #
    # LOGLEVEL = {Info|Warning|Error}
    LOGLEVEL = info
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21


    but FULLSCREEN=no does not seem to have any effect, games still run fullscreen no matter what.
    I am working on macOS High Sierra 10.13.4, Visionaire 5.0.4.

    Forum Fan

    119 Posts


  • #2, by afrlmeMonday, 30. April 2018, 13:07 2 years ago
    try resolution = auto

    resolution = desktop is forcing it to run the resolution of your pc.
    resolution = game is forcing it to run at the resolution you specified under game settings.
    resolution = 1280x720 is forcing it to run at a custom resolution value.

    By the way, are you running the game via the VS editor or is it an exported build? If you are running it via the VS editor & are forcing the game fullscreen in the options section then turn that & widescreen option off, otherwise it will ignore the resolution settings in the config.ini file. Your settings should look like this...

    https://i.gyazo.com/b92d1c1b415c181bb930b4f707ea8c19.png

    Imperator

    6772 Posts

  • #3, by fulviovMonday, 30. April 2018, 22:51 2 years ago
    Just tried setting it to auto, and it did not help.
    I am running the game from an exported build.

    Edit: tried every single option in the ini, game still runs fullscreen.

    Forum Fan

    119 Posts

  • #4, by afrlmeTuesday, 01. May 2018, 01:47 2 years ago
    Does the config.ini actually contain the line: file = mygame? It should actually link the the vis file you exported. data.vis or whatever you called it.

    Ok, another question. I assume this config.ini file you are editing is the one located in the same folder as the game files because that file is really only for the initial launch. It's possible that if you adjusted the volume levels of your game that you have automatically created a config.ini file inside of folder where the log files & save game files go. If a config.ini file exists there then it's possible that it is ignoring the one located in your games root folder.

    Imperator

    6772 Posts

  • #5, by sebastianTuesday, 01. May 2018, 15:07 2 years ago
    im not sure, but i never had it running in window mode automatically -even with the setting to No.

    As a workaround you may need to check if its true or false and switch to window mode if neccessary in the start action.

    EDIT:
    I guess this was caused in my case by running it through the Engine which forces fullscreen because of my settings. 

    Thread Captain

    2331 Posts

  • #6, by fulviovFriday, 04. May 2018, 10:55 2 years ago
    Does the config.ini actually contain the line: file = mygame? It should actually link the the vis file you exported. data.vis or whatever you called it.

    Ok, another question. I assume this config.ini file you are editing is the one located in the same folder as the game files because that file is really only for the initial launch. It's possible that if you adjusted the volume levels of your game that you have automatically created a config.ini file inside of folder where the log files & save game files go. If a config.ini file exists there then it's possible that it is ignoring the one located in your games root folder.
    Yes, the file is called mygame, it's a test game i was trying to try and debug the fullscreen problem.
    It does this with all other games as well.

    I found the other config file with the volume levels, I have deleted it, but the problem persists.

    Forum Fan

    119 Posts

  • #7, by fulviovFriday, 04. May 2018, 11:08 2 years ago
    im not sure, but i never had it running in window mode automatically -even with the setting to No.

    As a workaround you may need to check if its true or false and switch to window mode if neccessary in the start action.

    EDIT:
    I guess this was caused in my case by running it through the Engine which forces fullscreen because of my settings. 
    Hi Sebastian, that actually could work.
    Do you know by any chance the script command to set window and fullscreen mode?
    I know there is a toggle command, not sure if I can set the one or the other manually according to saved preferences.
    Thanks!

    Forum Fan

    119 Posts

  • #8, by afrlmeFriday, 04. May 2018, 12:15 2 years ago
    Here's the 3 relevant pages.

    https://wiki.visionaire-tracker.net/wiki/GetWindowMode -- check fullscreen/windowed
    https://wiki.visionaire-tracker.net/wiki/ToggleWindowMode -- toggle fullscreen/windowed
    https://wiki.visionaire-tracker.net/wiki/SetWindowSize -- force a resolution (for windowed mode)

    Imperator

    6772 Posts

  • #9, by fulviovSunday, 06. May 2018, 01:05 2 years ago
    Here's the 3 relevant pages.

    https://wiki.visionaire-tracker.net/wiki/GetWindowMode -- check fullscreen/windowed
    https://wiki.visionaire-tracker.net/wiki/ToggleWindowMode -- toggle fullscreen/windowed
    https://wiki.visionaire-tracker.net/wiki/SetWindowSize -- force a resolution (for windowed mode)
    Thanks! This workaround is perfect smile

    Forum Fan

    119 Posts

Write post