Problem with specific bitmap font

  • #1, by LebosteinTuesday, 10. March 2015, 19:46 6 years ago
    It seems the bitmap font detection works very fine. I have tested some special things and I've never had problems yet. But with this simple font I have problems now:

    https://dl.dropboxusercontent.com/u/13472834/visionaire/font_test.png

    Visionaire detects very large areas that makes the use impossible. What could be the problem with this font? I have some similar fonts with a very smooth edge like this and they work without problems. I have checked the areas between the chars. They are clean and full transparent (255).

    Key Killer

    601 Posts


  • #2, by LebosteinWednesday, 11. March 2015, 09:22 6 years ago
    Now the confusion is perfect. Following things are based on the same inkscape file. The first is rendered with Inkscape 0.47 on a Linux machine, the second one is rendered with Inkscape 0.91 (current version) on Mac OS. The output is nearly the same (a few pixels at the outer edge of the gloomy shine around the chars are different, but this is minimal).

    The first one is detected by Visionaire without problems:
    https://dl.dropboxusercontent.com/u/13472834/visionaire/font_test_works.png

    With the second one i get only large char areas over some chars (causes in crash of Visionaire some times):
    https://dl.dropboxusercontent.com/u/13472834/visionaire/font_test_problem.png

    I have no idea what the problem with the second one should be.

    PS: I am not sure what causes the thickness difference of the €-Symbol (the installed ttf font on both systems is the same). But I think this is not the reason of the problem.

    Key Killer

    601 Posts

Write post