Play Movie on object issue - video not shown

  • #1, by lupoTuesday, 02. April, 10:46 2 weeks ago
    Sorry guys, I didn`t get it to work and I have searched the community to find answers, but none of the given information did help me to get it to work. 

    Here is the issue:
    I `d like to have a video playing in the scene (like a star wars hologram)
    If I use the "Play Video" action, all works fine, but in Fullscreen only.

    - So I created a scene and placed an empty object in it (name: obj_VideoPosition)
    - I have another trigger (Name: VideoStart) which gets the action USE and when it gets used, there is a number of actions taking place: the hero says "Here it starts" (this works fine, so the trigger works), then there is a 500 ms pause (also this works fine) and then there is a Start Video on Object item (from the plugin), which contains the mkv. video (this can be tested via play button and works fine for preview purposes, so the file is correctly encoded), the item is linked to the object obj_VideoPosition. loop and blend is selected (but also tested it not selected without any effect).

    When the hero now pushes the trigger (use trigger), the hery says "Here it starts", the pause gets started and then nothing is happening. The video does`t play and I don`t get it to work.

    What kind of info does the obj_VideoPosition object need to play the video?

    Looking forward to your reply!
    Best





    Newbie

    4 Posts


  • #2, by esmeraldaTuesday, 02. April, 11:16 2 weeks ago
    the plugin is obsolete by now I think.

    You can play videos on objects via components.

    link a condition to your empty object obj_VideoPosition so you can turn it on and off (make it active and inactive)
    with the object selected in the list on the left, click on the components tab on the right, add a component, select "movie"
    There you can set the position and scale of the movie, and if it should loop.

    In your start object you can now change the condition on "use" to activate the object holding the video so it starts playing.

    Key Killer

    513 Posts

  • #3, by lupoTuesday, 02. April, 11:30 2 weeks ago
    WOW...less than 30 mins to a working solution! Awesome!
    Thank you very very very much!

    Newbie

    4 Posts

Write post