Pictures of objects disappear

  • #1, by ke4Monday, 16. June 2014, 11:13 6 years ago
    Hi,

    i started creating a menu, but when a load the game, some pictures of object disappear, but some doesn't. I can't find why :/
    Second, i'm afraid i don't undestand to new game button, i may set up action change scene, but when i use it, it works in the same way like resume, it means i need to reset all condition, values, items? Thank you.

    Key Killer

    810 Posts


  • #2, by afrlmeMonday, 16. June 2014, 13:17 6 years ago
    I've explained how to create a true new game button many times... I guess I really should include an article for it on the wiki! wink

    Long story short: you need to use the autosave/quicksave system.

    At the beginning of the first scene, you would create inside of the at begin on scene action part something like this... (action parts not lua script)
    if autosave #0 exists
    else
    pause for 10ms
    execute autosave #0
    end if
    1
    2
    3
    4
    5
    6

    Next inside of your new game button actions you would do something similar...
    if autosave #0 exists
    -- do some actions (play intro video or whatever)
    load autosave #0
    else
    - do whatever actions you were currently using...
    end if
    1
    2
    3
    4
    5
    6
    7

    The resume game button can also be approached in the same manner but the autosave #slot you assign for resume/autosave should be different from new game one & should be triggered inside of both the at begin & at end of scene (playable scene not menu scene) actions. This means that the autosave used in resume game will always be up to date; even if the player quits the game.

    Hope this quick/rough explanation helps you get an idea of what you have to do...

    Imperator

    6842 Posts

  • #3, by ke4Monday, 16. June 2014, 15:01 6 years ago
    Yes, i'm sorry, before i ask on forum i always look if there is a solution for what i need. I missed it.
    And for a lot of questions, there is always some new problem... confuse grin

    I tried, strange things happend. Things i set up for begging doesn't happened, and when i click on resume (bottom button) the text on the very beginning start again.
    ... what many problems are still waiting for me? without you my game would never be possible.
    So thanks a lot mate! - I will read the forum more carefully.

    (for the resume i have still just chcnage scene of character, i need to first undestand to this)

    Key Killer

    810 Posts

  • #4, by afrlmeMonday, 16. June 2014, 15:56 6 years ago
    Ok I'm guessing the display text is inside of an at begin of scene action yes? You need to get used to the idea of wrapping things in if queries; especially anything that is inside of an at begin of scene action or an action area inside of the way system for the scene. The reason for this is so that you query if a condition (or value) equals or does not equal something & if the condition is met then trigger the actions else ignore the actions inside of the if query.

    if else queries & conditions & values are mostly what your game will be made up from.

    Check this thread I wrote on the wiki about conditions & values, & their uses etc...

    Imperator

    6842 Posts

  • #5, by ke4Monday, 16. June 2014, 20:00 6 years ago
    i was still trying, but it finally works... I made maybe too much conditions, but it works.
    And the disappearing images after load, they were in the beginning hidden i changed "set object visibility" to making object active and inactive by condition and now it works too.

    Key Killer

    810 Posts

  • #6, by afrlmeMonday, 16. June 2014, 20:16 6 years ago
    nice one wink

    Imperator

    6842 Posts

  • #7, by ke4Wednesday, 18. June 2014, 14:49 6 years ago
    There is one more thing what doesn't work.
    i didn't have active any font in menu, if i active one, in the save menu cursour isn't visible. Is it a bug?
    And i was wondering is it possible to have only text without screenshots?

    Key Killer

    810 Posts

  • #8, by afrlmeWednesday, 18. June 2014, 15:26 6 years ago
    You mean to generate text via the engine itself instead of using images? I suppose it would be possible using "display object text" action part, but not tried doing that myself before. In theory you would still have to create a scene object to define the object area & actions.

    Quick question: have you created & assigned animations for both ACTIVE & INACTIVE for each cursor? If you have not, then that could explain why the cursor disappears when you hover over an object.

    Imperator

    6842 Posts

  • #9, by ke4Wednesday, 18. June 2014, 15:33 6 years ago
    Yes i have image for active and inactive too. The cursour isn't visible in the whole scene (menu) Only in the scene where are the save slots.
    I mean engine generate screenshots with text (date) i would like to the engine generate only text.

    Key Killer

    810 Posts

  • #10, by afrlmeWednesday, 18. June 2014, 16:15 6 years ago
    Ah no... You could create a custom save system yourself using the autosave/quicksave system & a bit of lua & some values, but it would require a fair amount of work & trial & error on your part.

    The default save system does the thumbnails & text (date) underneath (if you assigned text to save in scene properties tab).

    I can take a look at your .ved file if you like? I would need the resource files as well mind. If you want to give me then then you can send them inside of zip, rar or 7zip file to alternatingfrequencies (at) hotmail dot com, or via PM on here.

    Imperator

    6842 Posts

Write post