Particle system not displayed at all in game

  • #1, by VoltaicoTuesday, 19. August 2014, 22:26 6 years ago
    Hi everyone!
    I've been testing the particle system. The problem is a could not get it displayed in the game whatsoever. It's already selected in the "properties" tab of the scene and even linked to a bulb animation (pretends to be dust particles that are visible when the character lights a bulb).
    I can see the particle system working fine at the preview screen (I've made the particles big so they are clearly displayed on the screenshot), but in the game is not displayed by any means, nor at the beginning of the scene or when the bulb is On/Off.
    To make it clear, the bulb object and the bulb animation are different objects so the true/false condition do not interfere with the on/off cycle. I've got more conditions and actions attached to this object so I think that is not the problem.
    If I want the particle only visible when the animation is displayed do I need to select it at the properties of the scene too? I tried both and neither option works.
    Thanks in advance

    Newbie

    5 Posts


  • #2, by afrlmeTuesday, 19. August 2014, 23:11 6 years ago
    Hmm you shouldn't need to assign it to the scene. If you assign it to an object then the object controls the z-index of the particle system & the object also has to active - if you added a condition to said object & the condition is not met, then the object is inactive (hidden).

    Also did you set positioning of particles correctly in the particle system?

    When you assign particles to scene properties tab then the particles should play as soon as the scene loads & the particles should be on top of all the other layers.

    I've not actually tested to see if particle system was working in latest build, so if it's not something you've missed then it could be a bug.

    Imperator

    6842 Posts

  • #3, by AlexTuesday, 19. August 2014, 23:46 6 years ago
    did you set a particle texture (rendering tab of particle)?

    Great Poster

    378 Posts

  • #4, by VoltaicoWednesday, 20. August 2014, 00:25 6 years ago
    Hi! Thanks for the quick answers.
    The texture thing seems to do the trick, I didn't set one earlier because the preview already showed something similar to which I want and I thought it was not required.
    I must set the Particle type to "Quad" though, if I set "Lines" the particles don't show up no matter how big I made them, I suppose it has something to do with the particle texture.
    Which texture can be good to do a dust effect?
    Thanks!

    Newbie

    5 Posts

Write post