Non blocking "Pause" and "Send character to position"

  • #1, by spacepawThursday, 08. December 2011, 11:31 10 years ago
    Ok, Let's say I make a in-game cutscene and use "Pause" or "Send Character to Position" actions. During execution of those actions I can actually click and send character elsewhere (even send him to another scene!). It wouldn't be such a problem if the following actions didn't continue to execute - but they do. I wish there was some checkbox that allows input block during the execution of those actions (and probably in some more actions where it seems reasonable. Also Block/Unblock input action would be nice as well). This creates some serious bugs now ^^"

    Newbie

    0 Posts


  • #2, by SubbFriday, 09. December 2011, 17:27 10 years ago
    You can overcome this problem by hiding the cursor before the action parts start.

    But I agree that this is just a workaround. It would make sense to add an option in the game properties similar to the already existing "Disable interaction during character animations".

    And as were are about checkboxes, another wish from my side: I'd like to have a checkbox "Disable interfaces during dialogs". smile

    Newbie

    14 Posts

  • #3, by spacepawFriday, 09. December 2011, 23:11 10 years ago
    For some reason that doesn't work for me - the cursor is still shown...I'll check my scripts to see if they cause that. But really...Wrapping every walk to and pause IS a huge pain

    Newbie

    0 Posts

  • #4, by spacepawMonday, 12. December 2011, 10:58 10 years ago
    Update to those who are concerned: The "hide cursor" option didn't work for me because I used it in the action "in the beggining of the scene" and it seems that cursor is forced to be shown after fade in of the new scene. To be exact "in the beggining of the scene" action is called BEFORE scene fades in (which is a good thing of course) and after it fades in completely the cursor is forced to be shown. That's why I had to use "Pause" before "Hide cursor" with value around 475ms for a fade that's 600ms long. The problem is that the actual fade time varies and when I set the pause for 460ms cursor sometimes does get hidden and sometimes does not. This is not a good thing :/ But if you find yourself stuck with the same problem just remember to pause before hiding the cursor (the time of pause depends on your fade time but unfortunately it does not equal exactly fade time divided by 2) Please fix smile

    Newbie

    0 Posts

  • #5, by AlexTuesday, 13. December 2011, 18:54 10 years ago
    fixed it. The cursor can now be hidden in the actions 'at beginning of scene' and 'at end of scene'.

    Great Poster

    378 Posts

  • #6, by spacepawTuesday, 13. December 2011, 21:51 10 years ago
    Thank you very much Alex smile will it be in the next release or have you switched the build already? smile

    Newbie

    0 Posts

  • #7, by AlexWednesday, 14. December 2011, 00:02 10 years ago
    next release

    Great Poster

    378 Posts

Write post