New True Type fonts don't wrap at edge of screen

  • #1, by andiliddellTuesday, 12. August 2014, 23:26 6 years ago
    In V4.0 Final, the new True type fonts don't automatically wrap if the character is close to the edge of the screen when they speak, meaning some text gets cut off.

    Forum Fan

    178 Posts


  • #2, by afrlmeWednesday, 13. August 2014, 00:42 6 years ago
    I don't think it ever wrapped? Font image maps either. Probably best to set a custom automatic line break value.

    Imperator

    6842 Posts

  • #3, by SDMonoWednesday, 13. August 2014, 05:37 6 years ago
    In 3.7.1. it gets pushed to the side so it doesn't get cut. Haven't tried it in 4.0 yet!

    Forum Fan

    148 Posts

  • #4, by andiliddellWednesday, 13. August 2014, 18:40 6 years ago
    Yeah I thought that too. I've never noticed it getting cut off ever before?

    Setting the automatic break value, doesn't really help either. Sure it makes the lines shorter throughout, but still doesn't stop these short lines getting cut off at the screen edges.

    Forum Fan

    178 Posts

  • #5, by afrlmeWednesday, 13. August 2014, 19:02 6 years ago
    Not really sure what to suggest here other than position your character text in some kind of narration box or something... or don't allow your characters to get so close to the edge of the screen when talking.

    I vaguely remember text being pushed to the side in 3.7.1. But it didn't wrap or shorten itself.

    Imperator

    6842 Posts

  • #6, by AlexWednesday, 13. August 2014, 19:46 6 years ago
    could be a bug with truetype fonts. The ttf font should be pushed to the side so the whole text is visible, similar to the "old" fonts. We'll have a look at it.

    Great Poster

    378 Posts

  • #7, by andiliddellWednesday, 13. August 2014, 22:55 6 years ago
    Not sure if this has anything to do with it, but now I've found my messages.log file again, I'm getting these two lines about the true type font I'm using:

    21:54:16: Font "chickenFont_tt" (Id: 7): Number of font characters does not match with alphabet. Alphabet has 62 characters, but there are 0 characters in the font picture.
    21:54:16: Font 'chickenFont_tt' (id: 7) does not have a single character.

    The fonts appear fine on screen, no other issues apart from the cut off.

    Forum Fan

    178 Posts

  • #8, by afrlmeWednesday, 13. August 2014, 22:58 6 years ago
    I think that's in regards to the section where you type in the letters, but seeing as you are using ttf, you don't need to. I get similar error message too.

    Imperator

    6842 Posts

  • #9, by andiliddellWednesday, 20. August 2014, 00:32 6 years ago
    just to confirm Alex, the true type fonts, are not getting pushed to the side when your close to the edge in v4 full.

    This was the standard behaviour before (I must have imagined text wrapping smile ).

    Are there plans to fix this so it pushes to the side in next update?

    Many thanks

    Forum Fan

    178 Posts

  • #10, by andiliddellWednesday, 27. August 2014, 23:50 6 years ago
    Sorry to bang on about this bug, but can you confirm that this ttf font fix will be in the upcoming update for indie license V4.X

    I'm getting closer to a launch-able state, and it's messing up a lot of my dialogue, so until it's fixed I can't continue with user testing.

    I started to break some of the longer lines down in to multiples, but It changes the pacing and looks weird.

    Any idea of a date for the next patch would be hugely appreciated.

    Forum Fan

    178 Posts

  • #11, by SimonSThursday, 28. August 2014, 11:41 6 years ago
    Will be fixed in the next version, that might come soon, because of the RAM issues.

    Thread Captain

    1369 Posts

Write post