Mac visionaire games mouse cursor will not move unless a mouse button is pushed down [Solved]

  • #1, by anthonyirwin82Saturday, 05. September 2015, 06:02 5 years ago
    I have recently purchased a few games made with visionaire studio and also have the indie license for the development software.

    I have found that the mouse cursor does not move in the games both commercial released games and games run from the visionaire studio editor unless the mouse button is pushed in. If you move the mouse without having the mouse button pushed in the mouse cursor in the game does not move.

    I am running Mac OS X 10.10.5.

    I did some searches to try and find a solution to the problem and other people appear to have the same issue. I found the following links which is how I found out the mouse moves if you push the mouse button down. They are in German but I translated them to English with online translator.

    http://forum.daedalic.de/viewtopic.php?f=26&t=5171&sid=0fb35...
    http://forum.daedalic.de/viewtopic.php?f=21&t=5950&p=25769&h...

    I have not been able to find an answer to this problem can anyone help me out?

    Thanks
    Anthony

    Newbie

    16 Posts


  • #2, by SimonSSaturday, 05. September 2015, 09:52 5 years ago
    It affects other games as well:
    https://steamcommunity.com/discussions/forum/2/5283987197893...

    So it's a Mac problem. Try to use other mouse setups. We can't fix it. Or ask apple.
    Just for curiosity, what mouse do you use ?

    Thread Captain

    1333 Posts

  • #3, by anthonyirwin82Saturday, 05. September 2015, 14:52 5 years ago
    Its just a normal wireless mouse with a usb dongle plugged into the computer. I found if I turn the mouse off then back on again it will work properly with the game. Not sure why but it works.

    Newbie

    16 Posts

  • #4, by anthonyirwin82Sunday, 06. September 2015, 07:28 5 years ago
    Ok have done some more testing on Mac OS X 10.10.5 and Visionarie Studio 4.2 the following are my findings with the mouse issue I have been having:

    Macbook pro built in trackpad works perfectly
    iMac with official Apple Magic Mouse works perfectly

    Third party wireless mouse with usb dongle has issue where mouse does not move unless a mouse button is pressed in. I found if I turned the mouse off then back on again when in the game that the mouse would then work perfectly.

    Third party usb mouse with cord works perfectly.

    It seems as if some third party wireless mice in Mac OS X has issues but the official Apple hardware works fine and the only usb cord mouse I tried worked fine also.

    Newbie

    16 Posts

Write post