Mac OS color shift in full-screen mode - Bug?

  • #1, by klootWednesday, 09. April 2014, 14:58 6 years ago
    Hi, when I hit "Run game" in the Visionaire 4.0 editor on my Mac*, the screen gets an ugly blue tint - this is even before the game shows up. Looks like some color profile of the display is being switched off. When I take screenshots in-game and view them later, they are color-correct. So it's probably some display driver thing that the Visionaire player is doing. Never seen that with any other full-screen app. Any idea what's going on and how to fix? Thanks!

    * (Macbook 2009, OSX 10.9.2),

    Newbie

    14 Posts


  • #2, by BigStansWednesday, 09. April 2014, 21:43 6 years ago
    Hi,

    like this:

    ?
    But it can be SDL too. SDL has an "overlay on the mac" in the windowed mode, but i never seen this in fullscreen.
    Did you use an sRGB Profile?

    Great Poster

    361 Posts

  • #3, by klootWednesday, 09. April 2014, 22:24 6 years ago
    Thank you for your reply! Yeah, looking kind of like that. But correction: It does also happen in windowed mode, the blue tint appears every time the window gains focus.

    By sRGB, do you mean my game graphics? I think I probably exported some with an sRGB profile, I didn't give it much thought.

    Newbie

    14 Posts

  • #4, by BigStansWednesday, 09. April 2014, 23:16 6 years ago
    But the game looks correctly? I think it's an SDL brightness thing. SDL makes an "overlay" at the screen, but the game looks like the editor view.

    Great Poster

    361 Posts

  • #5, by klootThursday, 10. April 2014, 14:12 6 years ago
    Recorded video of this in windowed mode. This is an empty test project with an empty scene + character. See the tint appear + disappear as the window gains/loses focus.

    >> Video (couldn't figure out how to embed this here)

    Newbie

    14 Posts

  • #6, by BigStansFriday, 11. April 2014, 09:12 6 years ago
    Ah smile It's not an bug… It's an feature grin
    An little cosmetic -> fixed in the next update.
    If you are not useing the setWindowBrightness lua command or brightness setting in the .ini file it does not draw an overlay anymore.
    Thanks for the report smile

    Great Poster

    361 Posts

  • #7, by klootFriday, 11. April 2014, 14:15 6 years ago
    Ok, thanks so much! smile

    Newbie

    14 Posts

  • #8, by LebosteinSunday, 11. May 2014, 07:54 6 years ago
    Any news about this? The Whispered World SE from Daedalic was released yesterday WITH this bug...

    Key Killer

    598 Posts

Write post