int failed, could not load game (solved)

  • #1, by elecWednesday, 07. June 2017, 15:51 3 years ago
    I know, i know. Sigh.

    Okay, so i tried to make the game, i clicked the .exe
    aaaaaand

    i tried to look for the messages log but it seems it doesnt exist?

    Forum Fan

    109 Posts


  • #2, by afrlmeWednesday, 07. June 2017, 15:59 3 years ago
    It could be to do with how you exported the game. Can you post a screenshot of your build/export settings please?

    Imperator

    6808 Posts

  • #3, by elecWednesday, 07. June 2017, 16:02 3 years ago
    i kept it pretty much how it was, i tried it before ( a few months ago ) and everything seemed to work

    Forum Fan

    109 Posts

  • #4, by MachtnixWednesday, 07. June 2017, 16:30 3 years ago
    Do you have all necessary dll-files in your exe-folder?

    Sometimes this happens if you renamed the ved-file. Some links to your game-folder are broken. 

    Thread Captain

    1060 Posts

  • #5, by elecWednesday, 07. June 2017, 16:35 3 years ago
    i honestly dont know
    i deleted alot of files because they were part of the "test"exe, i hope now i didnt delete anything important :x
    do you mean i have to re adjust all the files in the game?!
    edit: i found the message log in the appdata folder and following seems to cause the problem:
    17:51:46: Warning: Illegal polygon border for action area 'Wald_Zweite_Szene: Gefahrenzone' (id: 0)
    i dont exactly know why this is the problem, because the action area should be all right, but im trying to find it out right now! ill keep you up2date

    edit 2:
    so i found another message log, i think i fixed the other one, this one says:

    18:09:07: Error: OpenGL init: invalid Framebuffer.
    18:09:07: Error: There must be at least one character for a valid game.
    18:09:07: Error: Failed to initialize game.
    18:09:07: Error: Init failed, could not load game

    im not quite sure what invalid framebuffer means, but im pretty sure i got plenty of characters in the game..?

    Forum Fan

    109 Posts

  • #6, by elecWednesday, 07. June 2017, 18:45 3 years ago
    ok i think i got the problem, even though it has NOTHING to do with what was written in the message log
    my video files were too big, so i used another format and now its working. sorry to bother you guys, thanks for your help tho

    Forum Fan

    109 Posts

  • #7, by afrlmeWednesday, 07. June 2017, 19:31 3 years ago
    All of those log errors were just warnings. Nearly everyone sees the openGL related ones. As for illegal polygon it's likely due to creating an overly complex interaction polygon for a scene object or because you accidentally created a stray polygon point or 2 that creates a shape that isn't closed off correctly.

    Format for videos should be mkv with vp8 as video codec & ogg or opus as audio codec. Audio should be ogg or opus. Images should be png or webp. These are the only formats I recommend using for visionaire studio as others require licenses or don't always work correctly & can cause the engine to crash - mp3 mostly.

    Imperator

    6808 Posts

  • #8, by elecWednesday, 07. June 2017, 20:28 3 years ago
    my video programm cant export into mkv, and when i convert the videos to mkv via a different programm the quality goes too much down, so i cant do mkv videos sadly

    Forum Fan

    109 Posts

  • #9, by MachtnixWednesday, 07. June 2017, 21:08 3 years ago
    It could be interesting to know, HOW BIG the videos were, so developers can guess the limits in future. I never have used (... Past Pefect...?) imported video-containers, but frames - and 400 frames is the magical border Visionaire will be really slower (on 32 bit).

    Thread Captain

    1060 Posts

  • #10, by afrlmeWednesday, 07. June 2017, 22:19 3 years ago
    my video programm cant export into mkv, and when i convert the videos to mkv via a different programm the quality goes too much down, so i cant do mkv videos sadly
    There's a page on the wiki David wrote about recommended video formats & how to convert to them. You should be able to convert while keeping same quality as source video.

    https://wiki.visionaire-tracker.net/wiki/Video_Encoding

    Also I think Ke4 knows a fair bit about mkv format now as well as how to include subtitles/additional audio language tracks, etc. I'm not very savvy on the video stuff myself as I've not personally needed to deal with it so far.

    Imperator

    6808 Posts

  • #11, by gabartsThursday, 08. June 2017, 08:50 3 years ago
    A solution for video size, I use webm and cloud converter online, it goes from 300 mb to 100 kb! And the quality seems pretty the same! Sort of Pied Piper thing lol!

    Forum Fan

    136 Posts

Write post