How to prevent skipping player & Narration text by clicking mouse

  • #1, by AkcayKaraazmakThursday, 01. March 2018, 11:59 2 years ago
    Hi mates,

    I dont want user to skip the naration or the player text. I tried hide mouse and didnt work. Also tried begin end cut scene also i didnt work. I dont see the mouse but when I click it skips the text and shows the next naration text or player text.

    p.s Also how I can prevent player to use ESC, it was on my previous post still can't find a solution for it:\

    Thank you guys...

    Great Poster

    437 Posts


  • #2, by sebastianThursday, 01. March 2018, 12:09 2 years ago
    Regarding the mouse:

    There is an option in the main game settings "Always allow to skip active text". When this is active you can skip cutscene text. In your case it should be deselected and around avery non-skippable display text you could wrap cutscene start/end action parts

    Thread Captain

    2336 Posts

  • #3, by afrlmeThursday, 01. March 2018, 12:29 2 years ago
    Regarding the mouse:

    There is an option in the main game settings "Always allow to skip active text". When this is active you can skip cutscene text. In your case it should be deselected and around avery non-skippable display text you could wrap cutscene start/end action parts

    Which will allow players to skip them with the ESC (escape) key still. Use the option on the main game settings section Sebastian mentioned & wrap texts with hide/show cursor action parts to completely disable skipping.

    Imperator

    6816 Posts

  • #4, by AkcayKaraazmakThursday, 01. March 2018, 12:37 2 years ago
    I already deselect "Always allow to skip active text" but no difference. I'm testing the game from saved files. Maybe to make "Always allow to skip active text" works, I should start to test the game from begging?

    And how about ESC mate? You wrote me that you can completely disable it when I dont need it? How can disable ESC?

    Great Poster

    437 Posts

  • #5, by afrlmeThursday, 01. March 2018, 12:48 2 years ago
    I just linked how to disable escape in the other thread. & old save files can cause conflict issues when you use old save files on ved/vis with new data/content, which is why it's recommended never to use existing save files while actively working on your project.

    Imperator

    6816 Posts

  • #6, by AkcayKaraazmakThursday, 01. March 2018, 12:52 2 years ago
    I'll see mate, try testing it from beginning

    Great Poster

    437 Posts

Write post