How can I stop visionaire from scaling a character

  • #2, by afrlmeTuesday, 07. January 2014, 00:07 7 years ago
    inside of the characters properties tab is a checkbox option: "scale character" - just untick it to prevent it from scaling character automatically to the way system scale points values.

    alternatively if the character is the only character on that particular scene then just don't add any scale values to any of the walk path points... or set top & bottom most points to same value.

    also to enable/disable the scale character option (in game) for the current character or any other character, you need to use a line of lua script to do it as there is action part available for changing it in game.

    "execute a script" action part then add one of the lines of code below...
    -- disable character scaling for current character
    game:getLink(VGameCurrentCharacter):setValue(VCharacterScale, false)

    -- enable character scaling for current character
    game:getLink(VGameCurrentCharacter):setValue(VCharacterScale, false)
    1
    2
    3
    4
    5
    6

    you can of course do this for any character at all, like so...
    getObject("Characters[add a characters name here]"):setValue(VCharacterScale, true)
    1
    2


    If you need any more help then just let me know.

    Imperator

    6846 Posts


  • #3, by afrlmeTuesday, 07. January 2014, 01:29 7 years ago
    no problem smile

    Imperator

    6846 Posts

Write post