Fullscreen Mode on a Dual Display

  • #1, by joemidTuesday, 19. April 2016, 20:48 4 years ago
    Hi all!

    When I play a Visionaire Game on PC with two monitors, I can click outside of the game and select the desktop- switching out of the game. Is there something I do about this? Built on a Mac laptop- retina. Tabs were checked for fullscreen-support. Config.ini = desktop. Fullscreen = yes.

    A possible clue- I was playing Demon Souls (#1) and it had the same issue. Other games do not. What am I missing here?! Wait- is it controller support?! I'm gonna check that with a lua script right now...

    Thanks!

    Newbie

    87 Posts


  • #2, by afrlmeTuesday, 19. April 2016, 22:34 4 years ago
    I'm not sure. I also used dual monitors & I lose focus when I accidentally move the cursor over into the other monitor & click. My suggestion is to only use one monitor while playing the game. I don't know if there is anything the devs could do to prevent it from happening, but I guess I'll let them answer that themselves.

    Imperator

    6805 Posts

  • #3, by marchardWednesday, 28. March 2018, 21:55 2 years ago
    Hello everybody,

    Sorry for digging out this old thread again, but I couldn't find a solution for this problem.
    Does anybody know, how to avoid this?

    Problem is as described above. My build VS game runs in Win7 in fullscreen mode on the main monitor on a system with two monitors. When I accidentally click on the second monitor, the game loses focus and the VS game is minimized and send to the taskbar.

    This is quite annoying, because in mine and many other adventure games there are
    sometimes hotspots at the far right of the screen and one accidentally clicks on the second screen.

    I play a lot PC games and most of the commercial games, don't have this problem. How can this be done with VS?

    Any help would be welcome.

    Newbie

    40 Posts

  • #4, by SimonSWednesday, 28. March 2018, 22:26 2 years ago
    If you want to lock the cursor, you can add

    LockCursor = Enabled

    to the config.ini.

    Thread Captain

    1333 Posts

  • #5, by marchardWednesday, 28. March 2018, 23:14 2 years ago
    If you want to lock the cursor, you can add

    LockCursor = Enabled

    to the config.ini.
    Thx, I tried it, but unfortunately it doesn't have any effect. Still the game loses focus.

    Newbie

    40 Posts

Write post