Disable Scaling Entirely?

  • #1, by ygmantellMonday, 08. January 2018, 22:05 2 years ago
    So my game is an isometric type game, similar to STASIS.  Because of this, I really don't need the scaling functionality at all, and it's causing problems when setting waypoints, etc.

    Is there a way to just disable it entirely?
    (Maybe a checkbox in the main game settings in future versions? smile )

    Thanks!

    Great Poster

    274 Posts


  • #2, by esmeraldaMonday, 08. January 2018, 22:31 2 years ago
    I don't think there is a global setting for it, but if you don't set the scale via the waypoints there will be no scaling. That means "no scaling" is the default state of every game.
    Plus you can untick the checkbox in the character properties regarding the scaling.

    Great Poster

    389 Posts

  • #3, by ygmantellMonday, 08. January 2018, 22:36 2 years ago
    Hm... So I made my character a little bigger than I needed, then changed the scale factor to 50 in the character properties so it is the size I want.  I guess that's what messed it up.  But, if I don't set any scale in the waypoints, it still messes up.  So, I set the first point to 50 then it was fine from then on.
    I guess I just misunderstood the scaling system to begin with.

    Thanks!

    Great Poster

    274 Posts

  • #4, by esmeraldaMonday, 08. January 2018, 22:49 2 years ago
    Changing the general scaling factor only works if you tick the scale-character-box.
    But it doesn't show in the preview in the wayponts-tab. So it's a bit harder to find the right size. Especially if you combine general scaling and scaling via waypoints. (which I don't recommend)

    So you could just use the general scaling and forget about setting the size in the waypoints. But you need to start the game to see if the size of your character is the right size.

    Great Poster

    389 Posts

  • #5, by ygmantellMonday, 08. January 2018, 22:53 2 years ago
    Got it.  I did experiment a bit and found that 50 is the right size for my character. But, it seems that even if I don't set a scale factor per waypoint (and just leave it at -1) it still gives me issues.  I could just work around it and set it individually per waypoint though.

    Thanks!

    Great Poster

    274 Posts

  • #6, by afrlmeTuesday, 09. January 2018, 02:36 2 years ago
    Just create 2 way points on vertical axis outside of the way border for each scene. Set same value for both. Leave all way points inside of the way border set as -1.

    Also if you disable scaling for the character via the properties tab, you could set a custom scale value for the character with Lua script.
    game.CurrentCharacter.CharacterSize = 50
    1

    Imperator

    6842 Posts

  • #7, by ygmantellTuesday, 09. January 2018, 04:27 2 years ago
    Ah, got it! Thanks so much!
    ...Stupid question: Would that lua bit go in the script editor as a seperate script, or in an execute script action part?

    Thanks!

    Great Poster

    274 Posts

  • #8, by afrlmeTuesday, 09. January 2018, 04:46 2 years ago
    You could call it at the start of each scene. Or add it inside of an execute a script action part for the first frame of each of all your characters animations. Calling it once at the start of the scene should be enough though.

    Imperator

    6842 Posts

  • #9, by ygmantellTuesday, 09. January 2018, 15:07 2 years ago
    Cool, thanks!

    Great Poster

    274 Posts

Write post